summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNocifer2021-12-26 12:42:17 +0200
committerNocifer2021-12-26 12:42:17 +0200
commit8e6964ce546933efda7b3d100d64a544407b6d81 (patch)
tree113cb32180e04ebf7a67e57ef49d0b0823270a68
downloadaur-8e6964ce546933efda7b3d100d64a544407b6d81.tar.gz
v=2.26.4596.102,r=1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD45
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15883a8465f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = emacs-mozc
+ pkgdesc = Mozc module for Emacs
+ pkgver = 2.26.4596.102
+ pkgrel = 1
+ url = https://github.com/google/mozc
+ arch = x86_64
+ license = Apache
+ license = BSD
+ license = LGPL
+ license = custom
+ makedepends = bazel
+ makedepends = git
+ makedepends = pkgconf
+ makedepends = python-six
+ makedepends = qt5-base
+ depends = emacs
+ depends = mozc=2.26.4596.102
+ conflicts = emacs-mozc-ut2
+ conflicts = emacs-mozc-ut-united
+ conflicts = emacs-mozc-ut
+ source = emacs-mozc-git::git+https://github.com/google/mozc.git#commit=3735608
+ sha256sums = SKIP
+
+pkgname = emacs-mozc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff121a4c2ce1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Nocifer <apmichalopoulos at gmail dot com>
+# Contributor: UTUMI Hirosi <utuhiro78 at yahoo dot co dot jp>
+# Contributor: Felix Yan <felixonmars@gmail.com>
+# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
+
+
+pkgname='emacs-mozc'
+pkgver=2.26.4596.102
+pkgrel=1
+pkgdesc='Mozc module for Emacs'
+arch=('x86_64')
+url='https://github.com/google/mozc'
+license=('Apache' 'BSD' 'LGPL' 'custom')
+depends=('emacs' 'mozc=2.26.4596.102')
+makedepends=('bazel' 'git' 'pkgconf' 'python-six' 'qt5-base')
+conflicts=('emacs-mozc-ut2' 'emacs-mozc-ut-united' 'emacs-mozc-ut')
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=3735608")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}-git
+
+ git submodule update --init --recursive
+
+ cd src
+
+ # Fix the Qt5 include path
+ sed -i -e 's/x86_64-linux-gnu\/qt5/qt/' config.bzl
+}
+
+build() {
+ cd ${pkgname}-git/src
+
+ env PATH="/usr/lib/jvm/java-11-openjdk/bin/:$PATH" bazel build unix/emacs:mozc_emacs_helper --config oss_linux --compilation_mode opt
+}
+
+package() {
+ cd ${pkgname}-git/src
+
+ install -Dm644 ../LICENSE ${pkgdir}/usr/share/licenses/emacs-mozc/LICENSE
+ install -Dm644 data/installer/credits_en.html ${pkgdir}/usr/share/licenses/emacs-mozc/credits_en.html
+
+ install -Dm755 bazel-bin/unix/emacs/mozc_emacs_helper ${pkgdir}/usr/bin/mozc_emacs_helper
+ install -Dm644 unix/emacs/mozc.el ${pkgdir}/usr/share/emacs/site-lisp/mozc.el
+}