summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNocifer2023-01-21 20:34:33 +0200
committerNocifer2023-01-21 20:34:33 +0200
commit8eccabbba729e927207183918884efd8637f8508 (patch)
tree794016e1e203ea33970f20c89e49afdc26aca109
parent8b98310192b93a7de3f60314acd2748fc6c8c902 (diff)
downloadaur-8eccabbba729e927207183918884efd8637f8508.tar.gz
v=2.28.4990.102,r=1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbfab1c7b089..a7ddfe7003bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = emacs-mozc
pkgdesc = Mozc module for Emacs
- pkgver = 2.28.4960.102
+ pkgver = 2.28.4990.102
pkgrel = 1
url = https://github.com/google/mozc
arch = x86_64
license = Apache
- license = BSD
+ license = GPL
license = LGPL
+ license = MIT
license = custom
makedepends = bazel
makedepends = git
makedepends = python
makedepends = qt5-base
depends = emacs
- depends = mozc>=2.28.4960.102
+ depends = mozc>=2.28.4990.102
options = !distcc
options = !ccache
- source = emacs-mozc-git::git+https://github.com/google/mozc.git#commit=7ec82c9356dbd5e15736627cfef05ec0f2c9bb9b
+ source = emacs-mozc-git::git+https://github.com/google/mozc.git#commit=811cb8c7606a4732a83abb89752664eb23728623
sha256sums = SKIP
pkgname = emacs-mozc
diff --git a/PKGBUILD b/PKGBUILD
index de5a878e333d..f422d00219eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,22 @@
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
pkgname='emacs-mozc'
-pkgver=2.28.4960.102
+pkgver=2.28.4990.102
pkgrel=1
pkgdesc='Mozc module for Emacs'
arch=('x86_64')
url='https://github.com/google/mozc'
-license=('Apache' 'BSD' 'LGPL' 'custom')
-depends=('emacs' 'mozc>=2.28.4960.102')
+license=('Apache' 'GPL' 'LGPL' 'MIT' 'custom')
+depends=('emacs' 'mozc>=2.28.4990.102')
makedepends=('bazel' 'git' 'python' 'qt5-base')
options=(!distcc !ccache)
-source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=7ec82c9356dbd5e15736627cfef05ec0f2c9bb9b")
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=811cb8c7606a4732a83abb89752664eb23728623")
sha256sums=('SKIP')
prepare() {
cd ${pkgname}-git/src
git submodule update --init --recursive
-
- # Temp fix for Bazel 6.0.0
- sed -i -e 's|@bazel_tools//platforms|@platforms//os|' tools/cc_target_os/BUILD.bazel
}
build() {
@@ -37,7 +34,7 @@ package() {
cd ${pkgname}-git/src
install -Dm644 ../LICENSE ${pkgdir}/usr/share/licenses/emacs-mozc/LICENSE
- install -Dm644 data/installer/credits_en.html ${pkgdir}/usr/share/licenses/emacs-mozc/credits_en.html
+ install -Dm644 data/installer/credits_en.html ${pkgdir}/usr/share/licenses/emacs-mozc/Submodules
install -Dm755 bazel-bin/unix/emacs/mozc_emacs_helper ${pkgdir}/usr/bin/mozc_emacs_helper
install -Dm644 unix/emacs/mozc.el ${pkgdir}/usr/share/emacs/site-lisp/mozc.el