summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNocifer2022-09-04 12:12:21 +0300
committerNocifer2022-09-04 12:12:21 +0300
commitfb62a43d0b4c75633d164d8b238aba92dc488203 (patch)
tree530850a60eb78191a868cab40b77925a492832c3
parent7f0a1b6dd91e0577a089ed7c09fee31c2b3d72c2 (diff)
downloadaur-fb62a43d0b4c75633d164d8b238aba92dc488203.tar.gz
v=2.28.4830.102,r=1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3cece3c8082..440535dcd94d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-mozc
pkgdesc = Mozc module for Emacs
- pkgver = 2.28.4800.102
+ pkgver = 2.28.4830.102
pkgrel = 1
url = https://github.com/google/mozc
arch = x86_64
@@ -13,10 +13,10 @@ pkgbase = emacs-mozc
makedepends = python
makedepends = qt5-base
depends = emacs
- depends = mozc>=2.28.4800.102
+ depends = mozc>=2.28.4830.102
options = !distcc
options = !ccache
- source = emacs-mozc-git::git+https://github.com/google/mozc.git#commit=9dc923ab84f4f0369ba507848430c0bd42dbd01d
+ source = emacs-mozc-git::git+https://github.com/google/mozc.git#commit=bf5e3ce232f3afd6c807d9c3d75d41fea08befc5
sha256sums = SKIP
pkgname = emacs-mozc
diff --git a/PKGBUILD b/PKGBUILD
index 7b832eeb64e9..fbe3a61fa245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,16 @@
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
pkgname='emacs-mozc'
-pkgver=2.28.4800.102
+pkgver=2.28.4830.102
pkgrel=1
pkgdesc='Mozc module for Emacs'
arch=('x86_64')
url='https://github.com/google/mozc'
license=('Apache' 'BSD' 'LGPL' 'custom')
-depends=('emacs' 'mozc>=2.28.4800.102')
+depends=('emacs' 'mozc>=2.28.4830.102')
makedepends=('bazel' 'git' 'python' 'qt5-base')
options=(!distcc !ccache)
-source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=9dc923ab84f4f0369ba507848430c0bd42dbd01d")
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=bf5e3ce232f3afd6c807d9c3d75d41fea08befc5")
sha256sums=('SKIP')
prepare() {
@@ -25,6 +25,7 @@ prepare() {
build() {
cd ${pkgname}-git/src
+ unset ANDROID_NDK_HOME
export JAVA_HOME='/usr/lib/jvm/java-11-openjdk/'
bazel build unix/emacs:mozc_emacs_helper --config oss_linux --compilation_mode opt
}