summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Whatson2020-04-14 13:11:28 +1000
committerAndrew Whatson2020-04-14 14:11:45 +1000
commit98cb9fa37324310cd47b56c6dace23fa2c0df4d0 (patch)
tree5d12109da92f0d97b337eb3fd77106692f1c5c08
parent23c59d94b1307f3e9c7f6a59c68770f3b2a3b4b4 (diff)
downloadaur-98cb9fa37324310cd47b56c6dace23fa2c0df4d0.tar.gz
Update to build native-comp branch
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29986c91b7d8..ff66dccf2f7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = emacs-git
- pkgdesc = GNU Emacs. Development master branch.
- pkgver = 28.0.50.139945
+pkgbase = emacs-native-comp-git
+ pkgdesc = GNU Emacs. Development native-comp branch.
+ pkgver = 28.0.50.141681
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = emacs-git
depends = libotf
depends = harfbuzz
depends = gpm
+ depends = libgccjit
depends = gtk3
depends = libjpeg-turbo
depends = giflib
@@ -23,13 +24,15 @@ pkgbase = emacs-git
conflicts = emacs
conflicts = emacs26-git
conflicts = emacs-27-git
+ conflicts = emacs-git
conflicts = emacs-seq
replaces = emacs26-git
replaces = emacs27-git
+ replaces = emacs-git
replaces = emacs-seq
options = !strip
- source = emacs-git::git://git.savannah.gnu.org/emacs.git
+ source = emacs-git::git://git.savannah.gnu.org/emacs.git#branch=feature/native-comp
md5sums = SKIP
-pkgname = emacs-git
+pkgname = emacs-native-comp-git
diff --git a/PKGBUILD b/PKGBUILD
index ed21152c32ab..f17478a93ba5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Pedro A. López-Valencia <https://aur.archlinux.org/users/vorbote>
+# Maintainer: Andrew Whatson <https://aur.archlinux.org/account/flatwhatson>
+# Maintainer of emacs-git: Pedro A. López-Valencia <https://aur.archlinux.org/users/vorbote>
################################################################################
# CAVEAT LECTOR: This PKGBUILD is highly opinionated. I give you
@@ -57,19 +58,19 @@ NOGZ="YES" # Don't compress .el files.
################################################################################
################################################################################
-pkgname="emacs-git"
-pkgver=28.0.50.139945
+pkgname="emacs-native-comp-git"
+pkgver=28.0.50.141681
pkgrel=1
-pkgdesc="GNU Emacs. Development master branch."
+pkgdesc="GNU Emacs. Development native-comp branch."
arch=('x86_64' )
url="http://www.gnu.org/software/emacs/"
license=('GPL3' )
-depends=('alsa-lib' 'gnutls' 'libxml2' 'jansson' 'libotf' 'harfbuzz' 'gpm')
+depends=('alsa-lib' 'gnutls' 'libxml2' 'jansson' 'libotf' 'harfbuzz' 'gpm' 'libgccjit')
makedepends=('git')
provides=('emacs' 'emacs-seq')
-conflicts=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq')
-replaces=('emacs26-git' 'emacs27-git' 'emacs-seq')
-source=("emacs-git::git://git.savannah.gnu.org/emacs.git")
+conflicts=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-git' 'emacs-seq')
+replaces=('emacs26-git' 'emacs27-git' 'emacs-git' 'emacs-seq')
+source=("emacs-git::git://git.savannah.gnu.org/emacs.git#branch=feature/native-comp")
# If Savannah access is blocked for reasons, use Github instead.
# Edit the config file of your local repo copy as well.
#source=("emacs-git::git://github.com/emacs-mirror/emacs.git")
@@ -188,6 +189,7 @@ build() {
# Good luck!
--without-gconf
--without-gsettings
+ --with-nativecomp
)
################################################################################
@@ -261,7 +263,7 @@ fi
# Please note that incremental compilation implies that you
# are reusing your src directory!
#
- make
+ make NATIVE_FAST_BOOT=1
# You may need to run this if 'loaddefs.el' files become corrupt.
#cd "$srcdir/emacs-git/lisp"