summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-03 20:36:53 +0200
committersballert2018-09-03 20:36:53 +0200
commit6e55dddcc122046f9cbbe614c6aebec9b936b2bd (patch)
treec1c4ac9ea180cce08b7d713fea95d9af9f56c272
downloadaur-emacs-neotree-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8348e5a53d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-neotree-git
+ pkgdesc = A emacs tree plugin like NerdTree for Vim.
+ pkgver = r359.4f8d80f
+ pkgrel = 1
+ url = https://github.com/jaypei/emacs-neotree
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-neotree
+ conflicts = emacs-neotree
+ source = git+https://github.com/jaypei/emacs-neotree.git
+ sha256sums = SKIP
+
+pkgname = emacs-neotree-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a183d85c3e14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="jaypei"
+_gitrepo="emacs-neotree"
+
+pkgname=emacs-neotree-git
+pkgver=r359.4f8d80f
+pkgrel=1
+pkgdesc="A emacs tree plugin like NerdTree for Vim."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-neotree')
+conflicts=('emacs-neotree')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/neotree/
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/neotree/icons
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/neotree/
+ install -m644 icons/*.xpm "$pkgdir"/usr/share/emacs/site-lisp/neotree/icons/
+}