summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2023-03-26 16:50:26 +0200
committerhaawda2023-03-26 16:50:26 +0200
commit4371504bacd047355d7e6124d8f8e5591faab8bd (patch)
treef464ada48b158a052f5f5b60c166b483fb7e2b2b
parent79241273926c79ad3f19cd788be79573e48ce73d (diff)
downloadaur-4371504bacd047355d7e6124d8f8e5591faab8bd.tar.gz
disable webrender
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD36
2 files changed, 29 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7aec52eae2cc..6d4feaf8e2b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-ng
pkgdesc = A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender
pkgver = 30.0.50
- pkgrel = 8
+ pkgrel = 9
url = https://emacs-ng.github.io/emacs-ng
arch = x86_64
license = GPL3
@@ -35,7 +35,7 @@ pkgbase = emacs-ng
depends = libwebp
provides = emacs
conflicts = emacs
- source = emacs-ng-d17245a.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.d17245a.tar.gz
- sha256sums = e1b8809e051bb46680bc3e6e25533d6b905f71cf39a09f0f827cd0520183d055
+ source = emacs-ng-1ce413e.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.1ce413e.tar.gz
+ sha256sums = 00ca2dd49671952849c062d127cbf7fe4d0b8fba3a212f8d0129771f52667a92
pkgname = emacs-ng
diff --git a/PKGBUILD b/PKGBUILD
index 1a3b043683e3..054e58017673 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=emacs-ng
pkgver=30.0.50
-_fix_commit=d17245a
-pkgrel=8
+_fix_commit=1ce413e
+pkgrel=9
pkgdesc="A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender"
arch=('x86_64')
url="https://emacs-ng.github.io/emacs-ng"
@@ -17,8 +17,9 @@ depends=('jansson' 'ncurses' 'libgccjit' 'librsvg' 'libxcb' 'libxml2' 'gpm'
'gtk3' 'libsm' 'xcb-util' 'libxcb' 'libwebp')
makedepends=('cargo' 'rustup' 'git' 'python' 'texlive-core')
source=("$pkgname-$pkgver_${_fix_commit}.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.${_fix_commit}.tar.gz")
+sha256sums=('00ca2dd49671952849c062d127cbf7fe4d0b8fba3a212f8d0129771f52667a92')
+
#source=(git+https://github.com/emacs-ng/emacs-ng)
-sha256sums=('e1b8809e051bb46680bc3e6e25533d6b905f71cf39a09f0f827cd0520183d055')
prepare() {
cd ${pkgname}-0.0.${_fix_commit}
@@ -30,14 +31,29 @@ build() {
RUSTUP_TOOLCHAIN=$(cat rust-toolchain)
./autogen.sh
./configure CFLAGS="-Wl,-rpath,shared -Wl,--disable-new-dtags" \
- --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var \
- --with-json --with-modules --with-compress-install --with-threads \
- --with-included-regex --with-zlib --with-libsystemd --with-rsvg \
- --with-native-compilation=aot --without-imagemagick \
- --with-gpm --with-gtk --without-xaw3d --with-dbus --without-pop \
- --with-mailutils --with-gsettings --disable-build-details
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --with-json \
+ --with-modules \
+ --with-compress-install \
+ --with-threads \
+ --with-included-regex \
+ --with-zlib \
+ --with-libsystemd \
+ --with-rsvg \
+ --with-native-compilation=aot \
+ --without-imagemagick \
+ --with-gpm \
+ --without-xaw3d \
+ --with-dbus \
+ --without-pop \
+ --with-mailutils \
+ --with-gsettings \
+ --disable-build-details
- make V=1 PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH"
+ make V=1 PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH" bootstrap
make pdf
}