summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-03-27 20:23:00 +0200
committerhaawda2022-03-27 20:23:00 +0200
commit533c8c3cb9df576eb97b72346b76d3dda1612b3a (patch)
tree02657fa8775ca491aff3fd1f3bab0393d48bd916
parent7613ae4c4cce44e4a1e8639c76ca471915a1c13c (diff)
downloadaur-533c8c3cb9df576eb97b72346b76d3dda1612b3a.tar.gz
update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88da4b5962a2..569e6e6c6f50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = emacs-ng
pkgdesc = A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender
pkgver = 28.0.50
- pkgrel = 3
+ pkgrel = 4
url = https://emacs-ng.github.io/emacs-ng
arch = x86_64
license = GPL3
makedepends = rustup
makedepends = python
+ makedepends = texlive-core
depends = jansson
depends = ncurses
depends = libgccjit
@@ -31,7 +32,7 @@ pkgbase = emacs-ng
depends = zlib
provides = emacs
conflicts = emacs
- source = emacs-ng-8a7aea8.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.8a7aea8.tar.gz
- sha256sums = 61fd36dd9af3b6323721b2c2f3ac47034b5907b48a0119ec8da37c2910018383
+ source = emacs-ng-1e46579.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.1e46579.tar.gz
+ sha256sums = 13b09b7d01149fbf8095160fb9a94b8a84f10c58ad959456505227ba2bfbcb6b
pkgname = emacs-ng
diff --git a/PKGBUILD b/PKGBUILD
index b5b08a6724f4..b486c07d5908 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=emacs-ng
pkgver=28.0.50
-_fix_commit=8a7aea8
-pkgrel=3
+_fix_commit=1e46579
+pkgrel=4
pkgdesc="A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender"
arch=('x86_64')
url="https://emacs-ng.github.io/emacs-ng"
@@ -13,10 +13,11 @@ provides=('emacs')
conflicts=('emacs')
depends=('jansson' 'ncurses' 'libgccjit' 'librsvg' 'libxpm' 'libjpeg-turbo' 'libtiff'
'giflib' 'libpng' 'harfbuzz' 'libxcb' 'libxml2' 'gpm' 'dune' 'dbus' 'lcms2'
- 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'gnutls' 'cairo' 'zlib')
-makedepends=('rustup' 'python')
+ 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'gnutls' 'cairo' 'zlib'
+ )
+makedepends=('rustup' 'python' 'texlive-core')
source=("$pkgname-$pkgver_${_fix_commit}.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.${_fix_commit}.tar.gz")
-sha256sums=('61fd36dd9af3b6323721b2c2f3ac47034b5907b48a0119ec8da37c2910018383')
+sha256sums=('13b09b7d01149fbf8095160fb9a94b8a84f10c58ad959456505227ba2bfbcb6b')
prepare() {
cd ${pkgname}-0.0.${_fix_commit}
@@ -33,15 +34,17 @@ build() {
--with-threads --with-included-regex --with-zlib --with-cairo --with-libsystemd \
--with-rsvg --with-native-compilation --with-webrender --without-sound \
--without-imagemagick --with-gpm --with-dbus --without-pop --without-mailutils \
- --without-gsettings --with-all
+ --without-gsettings --with-all --disable-build-details
make NATIVE_FULL_AOT=1 \
- PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH"
+ PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH"
+ make pdf
}
package() {
cd ${pkgname}-0.0.${_fix_commit}
make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-pdf
# remove conflict with ctags package
mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}