summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-02-20 23:45:08 +0100
committerhaawda2022-02-20 23:45:08 +0100
commit794031662c4c5ce24cae868278ed4cb2351fdf96 (patch)
treee58bc6423211984f6cc7bc4ac244c1ced711aaab
parent665a78621c4501970e5d04ea47f4afc65a26986c (diff)
downloadaur-794031662c4c5ce24cae868278ed4cb2351fdf96.tar.gz
adopted and updated
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e33676311c5c..888ded700281 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = emacs-ng
pkgdesc = A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender
- pkgver = 0.0.1006c73
+ pkgver = 28.0.50
pkgrel = 1
url = https://emacs-ng.github.io/emacs-ng
arch = x86_64
license = GPL3
- makedepends = clang
makedepends = rustup
makedepends = python
depends = jansson
@@ -17,13 +16,10 @@ pkgbase = emacs-ng
depends = libtiff
depends = giflib
depends = libpng
- depends = gtk3
depends = harfbuzz
depends = libxcb
depends = libxml2
depends = gpm
- depends = libotf
- depends = m17n-lib
depends = hicolor-icon-theme
depends = desktop-file-utils
depends = alsa-lib
@@ -32,7 +28,7 @@ pkgbase = emacs-ng
depends = zlib
provides = emacs
conflicts = emacs
- source = https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.1006c73.tar.gz
- sha256sums = d1519aa594654ff8c881853b3cc215d92ef113e120ff2bd127bf2050a96371e9
+ source = emacs-ng-b071459.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.b071459.tar.gz
+ sha256sums = 768f58e4b9059d3fe29611194fcd7f5b781c42f5335e867eb8811ae576786f6d
pkgname = emacs-ng
diff --git a/PKGBUILD b/PKGBUILD
index 6126adf7a6d0..d69f2a50ef92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
-# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+# Contributor: Sainnhe Park <sainnhe@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-ng
-pkgver=0.0.1006c73
+pkgver=28.0.50
+_fix_commit=b071459
pkgrel=1
pkgdesc="A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender"
arch=('x86_64')
@@ -9,35 +11,36 @@ url="https://emacs-ng.github.io/emacs-ng"
license=('GPL3')
provides=('emacs')
conflicts=('emacs')
-depends=('jansson' 'ncurses' 'libgccjit' 'librsvg' 'libxpm' 'libjpeg-turbo' 'libtiff' 'giflib' 'libpng' 'gtk3' 'harfbuzz' 'libxcb' 'libxml2' 'gpm' 'libotf' 'm17n-lib' 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'gnutls' 'cairo' 'zlib')
-makedepends=('clang' 'rustup' 'python')
-source=("https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('d1519aa594654ff8c881853b3cc215d92ef113e120ff2bd127bf2050a96371e9')
+depends=('jansson' 'ncurses' 'libgccjit' 'librsvg' 'libxpm' 'libjpeg-turbo' 'libtiff'
+ 'giflib' 'libpng' 'harfbuzz' 'libxcb' 'libxml2' 'gpm'
+ 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'gnutls' 'cairo' 'zlib')
+makedepends=('rustup' 'python')
+source=("$pkgname-$pkgver_${_fix_commit}.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.${_fix_commit}.tar.gz")
+sha256sums=('768f58e4b9059d3fe29611194fcd7f5b781c42f5335e867eb8811ae576786f6d')
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-0.0.${_fix_commit}
rustup install "$(cat rust-toolchain)"
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-0.0.${_fix_commit}
RUSTUP_TOOLCHAIN=$(cat rust-toolchain)
./autogen.sh
./configure CFLAGS="-Wl,-rpath,shared -Wl,--disable-new-dtags" \
--prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var \
--with-json --with-modules --with-harfbuzz --with-compress-install \
--with-threads --with-included-regex --with-zlib --with-cairo --with-libsystemd \
- --with-rsvg --with-native-compilation --with-webrender \
- --without-sound --without-imagemagick --without-makeinfo --without-gpm --without-dbus \
- --without-pop --without-toolkit-scroll-bars --without-mailutils --without-gsettings \
- --with-all
+ --with-rsvg --with-native-compilation --with-webrender --without-sound \
+ --without-imagemagick --with-gpm --with-dbus --without-pop --without-mailutils \
+ --without-gsettings
+
make NATIVE_FULL_AOT=1 \
- PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH" \
- -j$(nproc)
+ PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH"
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-0.0.${_fix_commit}
make DESTDIR="$pkgdir" install
# remove conflict with ctags package