summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2023-02-20 18:32:47 +0100
committerhaawda2023-02-20 18:32:47 +0100
commitbba4b4b3583fa867a1df8ee1ff72a01c6d0df153 (patch)
tree5d9c65f787a41bbad142c8b346a4121b07de9e52
parentff76d129518a5a0c57d781e86ffa816c43ceb13e (diff)
downloadaur-bba4b4b3583fa867a1df8ee1ff72a01c6d0df153.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD59
2 files changed, 32 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e18be89e2b8d..627df6da3c16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-ng
pkgdesc = A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender
pkgver = 30.0.50
- pkgrel = 2
+ pkgrel = 3
url = https://emacs-ng.github.io/emacs-ng
arch = x86_64
license = GPL3
@@ -35,7 +35,7 @@ pkgbase = emacs-ng
depends = mailutils
provides = emacs
conflicts = emacs
- source = emacs-ng-487968c.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.487968c.tar.gz
- sha256sums = 733510d7101725f3997a498b5ec2849bde3e7dff237dc702be3ccab652822b2d
+ source = emacs-ng-81af881.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.81af881.tar.gz
+ sha256sums = 36c8305e13b01ae40d5a7bf4e1f67cf16b6a6b523e241f35c34429ffab5d718f
pkgname = emacs-ng
diff --git a/PKGBUILD b/PKGBUILD
index a97a4bdfef97..2c2af8c67643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=emacs-ng
pkgver=30.0.50
-_fix_commit=487968c
-pkgrel=2
+_fix_commit=81af881
+pkgrel=3
pkgdesc="A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender"
arch=('x86_64')
url="https://emacs-ng.github.io/emacs-ng"
@@ -18,41 +18,40 @@ depends=('jansson' 'ncurses' 'libgccjit' 'librsvg' 'libxpm' 'libjpeg-turbo' 'lib
makedepends=('rustup' 'git' 'python' 'texlive-core')
source=("$pkgname-$pkgver_${_fix_commit}.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.${_fix_commit}.tar.gz")
#source=(git+https://github.com/emacs-ng/emacs-ng)
-sha256sums=('733510d7101725f3997a498b5ec2849bde3e7dff237dc702be3ccab652822b2d')
+sha256sums=('36c8305e13b01ae40d5a7bf4e1f67cf16b6a6b523e241f35c34429ffab5d718f')
prepare() {
- cd ${pkgname}-0.0.487968c
- rustup install "$(cat rust-toolchain)"
+ cd ${pkgname}-0.0.${_fix_commit}
+ rustup install "$(cat rust-toolchain)"
}
build() {
- cd ${pkgname}-0.0.487968c
- RUSTUP_TOOLCHAIN=$(cat rust-toolchain)
- ./autogen.sh
- ./configure CFLAGS="-Wl,-rpath,shared -Wl,--disable-new-dtags" \
- --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var \
- --with-json --with-modules --with-harfbuzz --with-compress-install \
- --with-threads --with-included-regex --with-zlib --with-cairo --with-libsystemd \
- --with-rsvg --with-native-compilation=aot --with-webrender \
- --enable-webrender-x11 --without-sound --without-imagemagick --with-gpm \
- --with-dbus --without-pop --with-mailutils --without-gsettings \
- --without-gconf --with-all --disable-build-details
-
+ cd ${pkgname}-0.0.${_fix_commit}
+ RUSTUP_TOOLCHAIN=$(cat rust-toolchain)
+ ./autogen.sh
+ ./configure CFLAGS="-Wl,-rpath,shared -Wl,--disable-new-dtags" \
+ --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var \
+ --with-json --with-modules --with-harfbuzz --with-compress-install \
+ --with-threads --with-included-regex --with-zlib --with-cairo --with-libsystemd \
+ --with-rsvg --with-native-compilation=aot --with-webrender \
+ --enable-webrender-x11 --without-sound --without-imagemagick --with-gpm \
+ --with-dbus --without-pop --with-mailutils --without-gsettings \
+ --without-gconf --with-all --disable-build-details
- make NATIVE_FULL_AOT=1 \
- PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH"
- make pdf
+ make NATIVE_FULL_AOT=1 \
+ PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH"
+ make pdf
}
package() {
- cd ${pkgname}-0.0.487968c
- make DESTDIR="$pkgdir" install
- make DESTDIR="$pkgdir" install-pdf
-
- # remove conflict with ctags package
- mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
- mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
-
- # fix user/root permissions on usr/share files
- find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
+ cd ${pkgname}-0.0.${_fix_commit}
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-pdf
+
+ # remove conflict with ctags package
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+
+ # fix user/root permissions on usr/share files
+ find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
}