summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2021-06-21 14:42:03 +0800
committerSainnhe Park2021-06-21 14:42:03 +0800
commitf1097765e309be175a69cfb182b60e84be70dc1b (patch)
treec7398217d334e512090c8c6dd582d6569c40efeb
downloadaur-f1097765e309be175a69cfb182b60e84be70dc1b.tar.gz
init
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD46
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61264a795180
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = emacs-ng
+ pkgdesc = A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender
+ pkgver = 0.0.e58f270
+ pkgrel = 1
+ url = https://emacs-ng.github.io/emacs-ng
+ arch = x86_64
+ license = GPL3
+ makedepends = texinfo
+ makedepends = gnutls
+ makedepends = libxt
+ makedepends = clang
+ makedepends = rustup
+ depends = jansson
+ depends = ncurses
+ depends = libgccjit
+ depends = librsvg
+ depends = libxpm
+ depends = libjpeg-turbo
+ depends = libtiff
+ depends = giflib
+ depends = libpng
+ depends = gtk3
+ depends = harfbuzz
+ depends = libxcb
+ depends = libxml2
+ depends = gpm
+ depends = libotf
+ depends = m17n-lib
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ depends = alsa-lib
+ depends = gnutls
+ depends = cairo
+ depends = zlib
+ provides = emacs
+ conflicts = emacs
+ source = https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.e58f270.tar.gz
+ sha256sums = 3856b84cc2c0f9474ef3e9257b54422a4abf235302e0ac7f1eb0fdaf4688f133
+
+pkgname = emacs-ng
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21b641db7cfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+
+pkgname=emacs-ng
+pkgver=0.0.e58f270
+pkgrel=1
+pkgdesc="A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender"
+arch=('x86_64')
+url="https://emacs-ng.github.io/emacs-ng"
+license=('GPL3')
+provides=('emacs')
+conflicts=('emacs')
+depends=('jansson' 'ncurses' 'libgccjit' 'librsvg' 'libxpm' 'libjpeg-turbo' 'libtiff' 'giflib' 'libpng' 'gtk3' 'harfbuzz' 'libxcb' 'libxml2' 'gpm' 'libotf' 'm17n-lib' 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'gnutls' 'cairo' 'zlib')
+makedepends=('texinfo' 'gnutls' 'libxt' 'clang' 'rustup')
+source=("https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('3856b84cc2c0f9474ef3e9257b54422a4abf235302e0ac7f1eb0fdaf4688f133')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ RUSTUP_TOOLCHAIN=$(cat rust-toolchain)
+ ./autogen.sh
+ ./configure CFLAGS="-Wl,-rpath,shared -Wl,--disable-new-dtags" \
+ --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var \
+ --with-json --with-modules --with-harfbuzz --with-compress-install \
+ --with-threads --with-included-regex --with-zlib --with-cairo --with-libsystemd \
+ --with-rsvg --with-native-compilation --with-webrender \
+ --without-sound --without-imagemagick --without-makeinfo --without-gpm --without-dbus \
+ --without-pop --without-toolkit-scroll-bars --without-mailutils --without-gsettings \
+ --with-all
+ make NATIVE_FULL_AOT=1 \
+ PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH" \
+ -j$(($(nproc) * 2))
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ # remove conflict with ctags package
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+
+ # fix user/root permissions on usr/share files
+ _emacs_ver=$(ls "$pkgdir/usr/share/emacs" | grep '[[:digit:]].*')
+ find "$pkgdir"/usr/share/emacs/$_emacs_ver -exec chown root:root {} \;
+}
+