summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2023-02-15 08:17:32 +0100
committerhaawda2023-02-15 08:17:32 +0100
commitff76d129518a5a0c57d781e86ffa816c43ceb13e (patch)
tree23b08a2ddb035d12cfd4465d89e78fa91681656b
parent6736b971a275690358be1755823333a8d2c8e6c3 (diff)
downloadaur-ff76d129518a5a0c57d781e86ffa816c43ceb13e.tar.gz
new configure options
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 124c5675a971..e18be89e2b8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = emacs-ng
pkgdesc = A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender
pkgver = 30.0.50
- pkgrel = 1
+ pkgrel = 2
url = https://emacs-ng.github.io/emacs-ng
arch = x86_64
license = GPL3
makedepends = rustup
+ makedepends = git
makedepends = python
makedepends = texlive-core
depends = jansson
@@ -30,6 +31,8 @@ pkgbase = emacs-ng
depends = gnutls
depends = cairo
depends = zlib
+ depends = tree-sitter
+ depends = mailutils
provides = emacs
conflicts = emacs
source = emacs-ng-487968c.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.487968c.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 1314bd6875a9..a97a4bdfef97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=emacs-ng
pkgver=30.0.50
_fix_commit=487968c
-pkgrel=1
+pkgrel=2
pkgdesc="A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender"
arch=('x86_64')
url="https://emacs-ng.github.io/emacs-ng"
@@ -14,27 +14,30 @@ conflicts=('emacs')
depends=('jansson' 'ncurses' 'libgccjit' 'librsvg' 'libxpm' 'libjpeg-turbo' 'libtiff'
'giflib' 'libpng' 'harfbuzz' 'libxcb' 'libxml2' 'gpm' 'dune' 'dbus' 'lcms2'
'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'gnutls' 'cairo' 'zlib'
- )
-makedepends=('rustup' 'python' 'texlive-core')
+ 'tree-sitter' 'mailutils')
+makedepends=('rustup' 'git' 'python' 'texlive-core')
source=("$pkgname-$pkgver_${_fix_commit}.tar.gz::https://github.com/emacs-ng/emacs-ng/archive/refs/tags/v0.0.${_fix_commit}.tar.gz")
+#source=(git+https://github.com/emacs-ng/emacs-ng)
sha256sums=('733510d7101725f3997a498b5ec2849bde3e7dff237dc702be3ccab652822b2d')
prepare() {
- cd ${pkgname}-0.0.${_fix_commit}
+ cd ${pkgname}-0.0.487968c
rustup install "$(cat rust-toolchain)"
}
build() {
- cd ${pkgname}-0.0.${_fix_commit}
+ cd ${pkgname}-0.0.487968c
RUSTUP_TOOLCHAIN=$(cat rust-toolchain)
./autogen.sh
./configure CFLAGS="-Wl,-rpath,shared -Wl,--disable-new-dtags" \
--prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var \
--with-json --with-modules --with-harfbuzz --with-compress-install \
--with-threads --with-included-regex --with-zlib --with-cairo --with-libsystemd \
- --with-rsvg --with-native-compilation --with-webrender --without-sound \
- --without-imagemagick --with-gpm --with-dbus --without-pop --without-mailutils \
- --without-gsettings --with-all --disable-build-details
+ --with-rsvg --with-native-compilation=aot --with-webrender \
+ --enable-webrender-x11 --without-sound --without-imagemagick --with-gpm \
+ --with-dbus --without-pop --with-mailutils --without-gsettings \
+ --without-gconf --with-all --disable-build-details
+
make NATIVE_FULL_AOT=1 \
PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH"
@@ -42,7 +45,7 @@ build() {
}
package() {
- cd ${pkgname}-0.0.${_fix_commit}
+ cd ${pkgname}-0.0.487968c
make DESTDIR="$pkgdir" install
make DESTDIR="$pkgdir" install-pdf