summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-08-01 22:40:47 +0200
committerFabioLolix2021-08-01 22:40:47 +0200
commit11a44fcb155c3392a7d25228cf2fd1a980f5c95c (patch)
tree152f8beb3ef825a035af82777a3588fe8418ea2f
parent5dc2c352e91e26552c82e1f4892c1bec90023eff (diff)
downloadaur-11a44fcb155c3392a7d25228cf2fd1a980f5c95c.tar.gz
revision + some things copied from emacs-ng pkgbuild
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD79
2 files changed, 58 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbf3b5f66ff1..994747d176ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = emacs-ng-git
pkgdesc = A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender
- pkgver = 28.0.50
+ pkgver = r149638.79390ea31d
pkgrel = 1
- url = https://www.gnu.org/software/emacs/emacs.html
+ epoch = 1
+ url = https://emacs-ng.github.io/emacs-ng/
arch = x86_64
license = GPL3
+ makedepends = git
+ makedepends = rustup
depends = texinfo
depends = libjpeg-turbo
depends = libtiff
@@ -15,9 +18,6 @@ pkgbase = emacs-ng-git
depends = libotf
depends = m17n-lib
depends = gtk3
- depends = hicolor-icon-theme
- depends = desktop-file-utils
- depends = alsa-lib
depends = gnutls
depends = jansson
depends = cairo
@@ -25,14 +25,13 @@ pkgbase = emacs-ng-git
depends = ncurses
depends = libxml2
depends = libxt
- depends = rustup
depends = zlib
depends = libgccjit
- provides = emacs-ng=28.0.50
+ provides = emacs
+ provides = emacs-ng
conflicts = emacs
conflicts = emacs-ng
- source = emacs-ng::git+https://github.com/emacs-ng/emacs-ng.git
- sha1sums = SKIP
+ source = git+https://github.com/emacs-ng/emacs-ng.git
+ sha256sums = SKIP
pkgname = emacs-ng-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d2f68b55bdd3..e49a12870f1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,61 @@
-# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
-# Maintainer: alienzj <alienchuj@gmail.com>
-# Maintainer: Steven Tang <xosdy.t@gmail.com>
+# Maintainer:
+# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Sainnhe Park <sainnhe@gmail.com>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: alienzj <alienchuj@gmail.com>
+# Contributor: Steven Tang <xosdy.t@gmail.com>
# Contributor: Renchi Raju <renchi@green.tam.uiuc.edu>
-_basename=emacs-ng
-pkgname=${_basename}-git
-pkgver=28.0.50
+pkgname=emacs-ng-git
+pkgver=r149638.79390ea31d
pkgrel=1
+epoch=1
pkgdesc="A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender"
-arch=('x86_64')
-url="https://www.gnu.org/software/emacs/emacs.html"
-license=('GPL3')
-depends=('texinfo' 'libjpeg-turbo' 'libtiff' 'librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk3' 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'gnutls' 'jansson' 'cairo' 'harfbuzz' 'ncurses' 'libxml2' 'libxt' 'rustup' 'zlib' 'libgccjit')
-provides=(${_basename}=${pkgver})
-conflicts=("emacs" "emacs-ng")
-source=("emacs-ng::git+https://github.com/emacs-ng/emacs-ng.git")
-sha1sums=('SKIP')
+arch=(x86_64)
+url="https://emacs-ng.github.io/emacs-ng/"
+license=(GPL3)
+depends=(texinfo libjpeg-turbo libtiff librsvg gpm giflib libxpm libotf m17n-lib gtk3 gnutls
+ jansson cairo harfbuzz ncurses libxml2 libxt zlib libgccjit)
+makedepends=(git rustup)
+provides=(emacs emacs-ng)
+conflicts=(emacs emacs-ng)
+source=("git+https://github.com/emacs-ng/emacs-ng.git")
+sha256sums=('SKIP')
-build() {
- cd "${srcdir}/${_basename}"
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%-git}"
+ rustup install "$(cat rust-toolchain)"
+ RUSTUP_TOOLCHAIN=$(cat rust-toolchain)
./autogen.sh
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --with-x-toolkit=gtk3 \
- --with-xft \
- --with-wide-int \
- --with-modules \
- --with-cairo \
- --with-harfbuzz \
- --with-nativecomp \
- --with-webrender
- make -j8
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --with-x-toolkit=gtk3 \
+ --with-xft \
+ --with-wide-int \
+ --with-modules \
+ --with-cairo \
+ --with-harfbuzz \
+ --with-nativecomp \
+ --with-webrender
+
+ make NATIVE_FULL_AOT=1 \
+ PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH"
}
package() {
- cd "${srcdir}/${_basename}"
+ cd "${srcdir}/${pkgname%-git}"
make DESTDIR="${pkgdir}/" install
# remove conflict with ctags package