summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-03 18:10:28 +0200
committersballert2018-09-03 18:10:28 +0200
commitef38498dfea11799ed219c4c06b0693395afb9dd (patch)
tree1f2b938d42e56bb6289cd9a368d342c67533b0df
downloadaur-ef38498dfea11799ed219c4c06b0693395afb9dd.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..386512a1ff40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-no-littering-git
+ pkgdesc = Help keeping ~/.emacs.d clean
+ pkgver = r144.3f6d290
+ pkgrel = 1
+ url = https://github.com/emacscollective/no-littering
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-no-littering
+ conflicts = emacs-no-littering
+ source = git+https://github.com/emacscollective/no-littering.git
+ sha256sums = SKIP
+
+pkgname = emacs-no-littering-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c17682a04ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="emacscollective"
+_gitrepo="no-littering"
+
+pkgname=emacs-no-littering-git
+pkgver=r144.3f6d290
+pkgrel=1
+pkgdesc="Help keeping ~/.emacs.d clean"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-no-littering')
+conflicts=('emacs-no-littering')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}