summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Loupmon2017-04-19 01:14:13 +0200
committerVincent Loupmon2017-04-19 01:14:13 +0200
commit8593054ceb43738cee824068ab216687a01520ef (patch)
tree8a0035d49edbc0d09700b9d655c2f3c3b7b896e1
downloadaur-8593054ceb43738cee824068ab216687a01520ef.tar.gz
Pushing finished PKG
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD57
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bbb6613d071
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = emacs-nox-24bit
+ pkgdesc = The extensible, customizable, self-documenting real-time display editor, without X11 support patched for 24bit colouring
+ pkgver = 25.1
+ pkgrel = 1
+ url = http://www.gnu.org/software/emacs/emacs.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = dbus
+ depends = ncurses
+ depends = perl
+ depends = libxml2
+ depends = glib2
+ depends = gnutls
+ provides = emacs
+ conflicts = emacs emacs-nox emacs-24bit
+ source = ftp://ftp.gnu.org/gnu/emacs/emacs-25.1.tar.xz
+ source = ftp://ftp.gnu.org/gnu/emacs/emacs-25.1.tar.xz.sig
+ source = https://gist.githubusercontent.com/choppsv1/3364fd6658ef498b5e06151217187017/raw/b9ba9e9000685abecf7ad954050b182eaef823e1/emacs-25.1-24bit.diff
+ validpgpkeys = 28D3BED851FDF3AB57FEF93C233587A47C207910
+ sha256sums = 19f2798ee3bc26c95dca3303e7ab141e7ad65d6ea2b6945eeba4dbea7df48f33
+ sha256sums = SKIP
+ sha256sums = e07dfcbe420c8fd08cc3286d6779fda6ca29ee14b05ed0c47ea1f417b90ea9b1
+
+pkgname = emacs-nox-24bit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4be02c4c6906
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# $Id$
+# Maintainer: Vincent Loupmon <vincentloupmon@gmail.com>
+#
+# To enable 24 bit color in the terminal one must define the environment
+# variable ITERM_24BIT=1 or KONSOLE_DBUS_SESSION=1
+#
+# Derived from emacs-nox && emacs-24bit packages
+
+pkgname=emacs-nox-24bit
+pkgver=25.1
+pkgrel=1
+pkgdesc="The extensible, customizable, self-documenting real-time display editor, without X11 support patched for 24bit colouring"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/emacs/emacs.html"
+license=('GPL3')
+depends=('dbus' 'ncurses' 'perl' 'libxml2' 'glib2' 'gnutls')
+provides=('emacs')
+conflicts=('emacs emacs-nox emacs-24bit')
+source=(ftp://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.xz{,.sig}
+ https://gist.githubusercontent.com/choppsv1/3364fd6658ef498b5e06151217187017/raw/b9ba9e9000685abecf7ad954050b182eaef823e1/emacs-25.1-24bit.diff)
+
+validpgpkeys=('28D3BED851FDF3AB57FEF93C233587A47C207910')
+sha256sums=('19f2798ee3bc26c95dca3303e7ab141e7ad65d6ea2b6945eeba4dbea7df48f33'
+ 'SKIP'
+ 'e07dfcbe420c8fd08cc3286d6779fda6ca29ee14b05ed0c47ea1f417b90ea9b1')
+
+prepare() {
+ cd "$srcdir/emacs-${pkgver/_/}"
+ patch -Np1 -i ../emacs-25.1-24bit.diff
+}
+
+build() {
+ cd "${srcdir}"/emacs-$pkgver
+
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --without-x --without-sound
+ make
+}
+
+package() {
+ cd "${srcdir}"/emacs-$pkgver
+ make DESTDIR="${pkgdir}" install
+
+# remove conflict with ctags package
+ mv "${pkgdir}"/usr/bin/{ctags,ctags.emacs}
+ mv "${pkgdir}"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+
+# fix user/root permissions on usr/share files
+ find "${pkgdir}"/usr/share/emacs/$pkgver -exec chown root.root {} \;
+# remove .desktop file and icons
+ rm -rf "${pkgdir}"/usr/share/{applications,icons}
+# fix perms on /var/games
+ chmod 775 "${pkgdir}"/var/games
+ chmod 775 "${pkgdir}"/var/games/emacs
+ chmod 664 "${pkgdir}"/var/games/emacs/*
+ chown -R root:games "${pkgdir}"/var/games
+} \ No newline at end of file