summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinRs2019-04-30 19:50:34 +0800
committerLinRs2019-04-30 19:50:34 +0800
commit247d1e4f4ab842e119ffa6f373dd2b972c6cfecc (patch)
treef0b6c9e60c1d030374353b6a3a16a1ae959a96f3
parentc512e39c140eb3f9bd1ee06c658bd2b236f67549 (diff)
downloadaur-emacs-org-bullets-git.tar.gz
upgpkg: emacs-org-bullets-git 0.2.4.r11.gb56f2e3-1
adopt the package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 551698b9275f..4c2ee0fad47e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-org-bullets-git
pkgdesc = utf-8 bullets for org-mode
- pkgver = r58.b56f2e3
+ pkgver = 0.2.4.r11.gb56f2e3
pkgrel = 1
url = https://github.com/emacsorphanage/org-bullets
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 2a12db8b7786..8d5020d386e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: sballert <sballert@posteo.de>
+# Maintainer: LinRs <LinRs at users.noreply.github.com>
+# Contributor: sballert <sballert@posteo.de>
_gituser="emacsorphanage"
_gitrepo="org-bullets"
pkgname=emacs-org-bullets-git
-pkgver=r58.b56f2e3
+pkgver=0.2.4.r11.gb56f2e3
pkgrel=1
pkgdesc="utf-8 bullets for org-mode"
url="https://github.com/${_gituser}/${_gitrepo}"
@@ -19,16 +20,19 @@ sha256sums=('SKIP')
pkgver() {
cd "$_gitrepo"
- printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
cd "$_gitrepo"
- emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+ emacs -Q -batch -L . -f batch-byte-compile *.el
}
package() {
cd "$_gitrepo"
- install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
- install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -d "$pkgdir/usr/share/emacs/site-lisp/${_gitrepo}/"
+ install -m644 *.el{c,} "$pkgdir/usr/share/emacs/site-lisp/${_gitrepo}/"
}