summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-05 16:34:21 +0200
committersballert2018-09-05 16:34:21 +0200
commitc512e39c140eb3f9bd1ee06c658bd2b236f67549 (patch)
treeab538ec5499a697f6bd9caf1b7e74fbf23d2fa35
downloadaur-c512e39c140eb3f9bd1ee06c658bd2b236f67549.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..551698b9275f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-org-bullets-git
+ pkgdesc = utf-8 bullets for org-mode
+ pkgver = r58.b56f2e3
+ pkgrel = 1
+ url = https://github.com/emacsorphanage/org-bullets
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-org-bullets
+ conflicts = emacs-org-bullets
+ source = git+https://github.com/emacsorphanage/org-bullets.git
+ sha256sums = SKIP
+
+pkgname = emacs-org-bullets-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a12db8b7786
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="emacsorphanage"
+_gitrepo="org-bullets"
+
+pkgname=emacs-org-bullets-git
+pkgver=r58.b56f2e3
+pkgrel=1
+pkgdesc="utf-8 bullets for org-mode"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-org-bullets')
+conflicts=('emacs-org-bullets')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}