summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-05-06 09:43:01 +0200
committerhaawda2018-05-06 09:43:01 +0200
commit67c0b7100a6ff6d0c42937498cf137ef7028f1e4 (patch)
tree1f4eb30c2b7cce46ca8b2c8a702a533f1696e3b5
parent15484fff82d6d6255673014ea085be8b75c7399a (diff)
downloadaur-67c0b7100a6ff6d0c42937498cf137ef7028f1e4.tar.gz
build in build function, install in package function
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c21ae4c42e91..62c4dd51ca94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-org-mode-git
pkgdesc = Emacs Org Mode from git
- pkgver = 9.1.9.560.gf93aa77cc
+ pkgver = 9.1.13.726.g1dbc50608
pkgrel = 1
url = http://orgmode.org/
install = emacs-org-mode.install
@@ -13,7 +13,7 @@ pkgbase = emacs-org-mode-git
depends = emacs
optdepends = java-environment: for using ditaa.jar in the contrib directory
optdepends = zsh: for using dir2org.zsh in the contrib directory
- provides = emacs-org-mode=9.1.9.560.gf93aa77cc
+ provides = emacs-org-mode=9.1.13.726.g1dbc50608
conflicts = emacs-org-mode
source = emacs-org-mode::git+https://code.orgmode.org/bzg/org-mode.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ea694b365557..367fc4f94275 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-org-mode-git
-pkgver=9.1.9.560.gf93aa77cc
+pkgver=9.1.13.726.g1dbc50608
pkgrel=1
pkgdesc="Emacs Org Mode from git"
arch=('any')
@@ -23,6 +23,11 @@ pkgver() {
git describe --tags | sed 's+-+.+g' | cut -c9-
}
+ build() {
+ cd ${pkgname%-git}
+ make
+}
+
package () {
cd ${pkgname%-git}
# sed -i '30s+autoloads++' mk/targets.mk