summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2015-06-09 14:36:52 +0800
committerMort Yao2015-06-09 14:36:52 +0800
commit8f3c15f46c2ee68c6997c3130d33936a10e86346 (patch)
treeedbfe1f078c098e39970d88f34c662bcf7782d4f
downloadaur-8f3c15f46c2ee68c6997c3130d33936a10e86346.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--emacs-oz-mode.install7
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c52323f24e44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = emacs-oz-mode
+ pkgdesc = Major mode for editing Mozart/Oz.
+ pkgver = 20150609
+ pkgrel = 1
+ url = https://github.com/mozart/mozart2
+ install = emacs-oz-mode.install
+ arch = any
+ license = MIT
+ depends = emacs
+ source = https://raw.github.com/mozart/mozart2/master/opi/emacs/mozart.el
+ source = https://raw.github.com/mozart/mozart2/master/opi/emacs/oz.el
+ source = https://raw.github.com/mozart/mozart2/master/opi/emacs/oz-extra.el
+ source = https://raw.github.com/mozart/mozart2/master/opi/emacs/oz-server.el
+ md5sums = d1d1b4b1e55c06c265bfef27e51dc54c
+ md5sums = 3c7ef9f4280234e9a3b35ff05f38c33c
+ md5sums = 5b4a5acd817b21e9aa85d439ee14401f
+ md5sums = c175f79fb1251d65f4fb583f4625ffff
+
+pkgname = emacs-oz-mode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d34f20847a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mort Yao <soi@mort.ninja>
+
+pkgname=emacs-oz-mode
+pkgver=20150609
+pkgrel=1
+pkgdesc="Major mode for editing Mozart/Oz."
+arch=('any')
+url="https://github.com/mozart/mozart2"
+license=('MIT')
+depends=('emacs')
+install=$pkgname.install
+source=(
+ "https://raw.github.com/mozart/mozart2/master/opi/emacs/mozart.el"
+ "https://raw.github.com/mozart/mozart2/master/opi/emacs/oz.el"
+ "https://raw.github.com/mozart/mozart2/master/opi/emacs/oz-extra.el"
+ "https://raw.github.com/mozart/mozart2/master/opi/emacs/oz-server.el"
+)
+md5sums=('d1d1b4b1e55c06c265bfef27e51dc54c'
+ '3c7ef9f4280234e9a3b35ff05f38c33c'
+ '5b4a5acd817b21e9aa85d439ee14401f'
+ 'c175f79fb1251d65f4fb583f4625ffff')
+
+build() {
+ cd $srcdir
+ emacs -batch -f batch-byte-compile $srcdir/*.el
+}
+
+package() {
+ cd $srcdir
+ mkdir -p $pkgdir/usr/share/emacs/site-lisp/oz
+ install -Dm644 *.el *.elc $pkgdir/usr/share/emacs/site-lisp/oz
+}
diff --git a/emacs-oz-mode.install b/emacs-oz-mode.install
new file mode 100644
index 000000000000..fe940941b668
--- /dev/null
+++ b/emacs-oz-mode.install
@@ -0,0 +1,7 @@
+post_install() {
+ cat <<EOF
+==> Put this in your ~/.emacs file to use Oz mode:
+
+(require 'oz)
+EOF
+}