summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-09-09 15:56:34 +0200
committerhaawda2018-09-09 15:56:34 +0200
commit910e0658867550ae03b0220f8bd5d4c5adfcfe71 (patch)
tree4968ec6fc6fd3fe8dd2eed9a4d730cf4d6d5152a
downloadaur-910e0658867550ae03b0220f8bd5d4c5adfcfe71.tar.gz
initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--paredit.install17
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe87187092c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Sep 9 13:56:26 UTC 2018
+pkgbase = emacs-paredit-git
+ pkgdesc = Emacs minor mode for pseudo-structurally editing Lisp code
+ pkgver = r216.acbe10f
+ pkgrel = 1
+ url = http://www.emacswiki.org/emacs/ParEdit
+ install = paredit.install
+ arch = any
+ license = GPL
+ makedepends = emacs
+ makedepends = git
+ provides = paredit
+ conflicts = paredit
+ source = git+http://mumble.net/~campbell/git/paredit.git
+ sha256sums = SKIP
+
+pkgname = emacs-paredit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fedec082499
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-paredit-git
+pkgver=r216.acbe10f
+_pkgname=paredit
+pkgrel=1
+pkgdesc="Emacs minor mode for pseudo-structurally editing Lisp code"
+arch=('any')
+url="http://www.emacswiki.org/emacs/ParEdit"
+license=('GPL')
+conflicts=('paredit')
+provides=('paredit')
+makedepends=('emacs' 'git')
+install=paredit.install
+source=("git+http://mumble.net/~campbell/git/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd paredit
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd paredit
+ emacs -Q -batch -f batch-byte-compile paredit.el
+}
+
+check() {
+ cd paredit
+ . ./check.sh
+}
+
+package() {
+ cd paredit
+ install -D -m644 paredit.elc \
+ "$pkgdir"/usr/share/emacs/site-lisp/paredit.elc
+ install -D -m644 paredit.el \
+ "$pkgdir"/usr/share/emacs/site-lisp/paredit.el
+}
+
diff --git a/paredit.install b/paredit.install
new file mode 100644
index 000000000000..210acab0ad26
--- /dev/null
+++ b/paredit.install
@@ -0,0 +1,17 @@
+post_install() {
+ cat << 'EOF'
+==> Put this in your $HOME/.emacs file to enable autoloading of paredit:
+
+(autoload 'paredit-mode "paredit"
+ "Minor mode for pseudo-structurally editing Lisp code." t)
+
+==> Toggle Paredit Mode with `M-x paredit-mode RET', or enable it
+==> always in a major mode `M' (e.g., `lisp' or `scheme') with:
+
+(add-hook M-mode-hook (lambda () (paredit-mode +1)))
+EOF
+}
+
+post_upgrade() {
+ post_install
+}