summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-07 12:46:21 +0200
committersballert2018-09-07 12:46:21 +0200
commit9ab6e7153d089c6088a8d8af85f860f94fa7b8e9 (patch)
tree8a211ff129c9c746f78ced28f627b93b6e8dc09e
downloadaur-9ab6e7153d089c6088a8d8af85f860f94fa7b8e9.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c90a3cc79467
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = emacs-pdf-tools-git
+ pkgdesc = Emacs support library for PDF files.
+ pkgver = r841.8aa7aec
+ pkgrel = 1
+ url = https://github.com/politza/pdf-tools
+ arch = any
+ license = GPL3
+ checkdepends = git
+ checkdepends = cask
+ makedepends = git
+ makedepends = cask
+ depends = emacs
+ depends = emacs-tablist
+ depends = libpng
+ depends = zlib
+ depends = poppler-glib
+ optdepends = imagemagick: following links of a PDF document by plain keystrokes
+ provides = emacs-pdf-tools
+ conflicts = emacs-pdf-tools
+ source = git+https://github.com/politza/pdf-tools.git
+ sha256sums = SKIP
+
+pkgname = emacs-pdf-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ded6c16df52d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="politza"
+_gitrepo="pdf-tools"
+
+pkgname=emacs-pdf-tools-git
+pkgver=r841.8aa7aec
+pkgrel=1
+pkgdesc="Emacs support library for PDF files."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-tablist' 'libpng' 'zlib' 'poppler-glib')
+optdepends=('imagemagick: following links of a PDF document by plain keystrokes')
+makedepends=('git' 'cask')
+checkdepends=('git' 'cask')
+provides=('emacs-pdf-tools')
+conflicts=('emacs-pdf-tools')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+check() {
+ cd "$_gitrepo"
+ make check
+}
+
+build() {
+ cd "$_gitrepo"
+ make bytecompile
+ make server/epdfinfo
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -d "$pkgdir"/usr/bin
+ install -m644 lisp/*.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m755 server/epdfinfo "$pkgdir"/usr/bin/
+}