summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonHugo2018-07-06 23:09:39 +0200
committerDonHugo2018-07-06 23:09:39 +0200
commit3a43af05addfc88f1ae222fd47e0dd682daf1c9b (patch)
tree5e6751bf5f6f8b3f020d41bb14d089215017d10b
downloadaur-3a43af05addfc88f1ae222fd47e0dd682daf1c9b.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD342
-rw-r--r--pdump-patch.diff11
3 files changed, 378 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..546f5d881f7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = emacs-pdumper-git
+ pkgdesc = GNU Emacs. pdumper branch, which can allow very fast startup times.
+ pkgver = 27.0.50.132398
+ pkgrel = 1
+ url = http://www.gnu.org/software/emacs/
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = alsa-lib
+ depends = gnutls
+ depends = libxml2
+ depends = jansson
+ depends = gtk3
+ depends = libotf
+ depends = libjpeg-turbo
+ depends = giflib
+ provides = emacs
+ conflicts = emacs
+ source = emacs-git::git+https://github.com/emacs-mirror/emacs.git#branch=pdumper
+ source = pdump-patch.diff
+ md5sums = SKIP
+ md5sums = 8769fcfd87b5ec0a0ba8d8108d09b34f
+
+pkgname = emacs-pdumper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78f6f7fcbab2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,342 @@
+# Original submitter: A. López-Valencia <https://aur.archlinux.org/users/vorbote>
+
+# This package is based on vorbote's emacs-git package, all credit goes
+# there.
+
+#######################################################################
+# CAVEAT LECTOR: This PKGBUILD is highly opinionated. I give you
+# enough rope to hang yourself, but by default it
+# only enables the features I use.
+#
+# TLDR: yaourt users, cry me a river.
+#
+# Everyone else: do not update blindly this PKGBUILD. At least
+# make sure to compare and understand the changes.
+#
+#######################################################################
+
+#######################################################################
+# Track a maintenance branch or, by default, track master.
+#
+# Pick a branch from the output of "git branch" ran on your local copy
+# of the emacs repository.
+#
+# E.g.:
+#
+# BRANCH=master
+# BRANCH=emacs-26
+#
+# Take note that I don't expect you to track anything different to master
+# or emacs-26 for obvious reasons. (See below).
+#
+BRANCH=pdumper
+
+#######################################################################
+# Assign "YES" to the variable you want enabled; empty or other value
+# for NO.
+#
+# Where you read experimental, replace with foobar.
+# =================================================
+#
+#######################################################################
+CHECK= # Run tests. May fail, this is developement after all.
+CLANG= # Use clang.
+LTO= # Enable link-time optimization. Experimental.
+CLI= # CLI only binary.
+NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
+ #
+ # Read https://wiki.archlinux.org/index.php/X_resources
+ # https://en.wikipedia.org/wiki/X_resources
+ # and https://www.emacswiki.org/emacs/XftGnuEmacs
+ # for some tips on using outline fonts with
+ # Xft, if you choose no toolkit or Lucid.
+ #
+LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
+GTK2= # GTK2.
+GPM= # Enable gpm support.
+M17N= # Enable m17n international table input support.
+ # You are far better off using UTF-8 and an input
+ # method under X/Wayland. But this gives independence
+ # if you need it.
+OTF="YES" # OTF font support. Also a secondary dependency
+ # by pulling m17n-lib. Not needed in that case.
+CAIRO= # Highly experimental. Maintaner dissapeared.
+XWIDGETS= # Use GTK+ widgets pulled from webkit2gtk. Usable.
+DOCS_HTML= # Generate and install html documentation.
+DOCS_PDF= # Generate and install pdf documentation.
+MAGICK= # Imagemagick 6 libraries support. Imagemagick,
+ # like flash, is bug ridden and won't die; yet useful.
+NOGZ= # Don't compress el files.
+#######################################################################
+
+#######################################################################
+if [[ $BRANCH = "pdumper" ]]; then
+ pkgname=emacs-pdumper-git
+else
+ pkgname=emacs-git
+fi
+pkgver=27.0.50.132398
+pkgrel=1
+pkgdesc="GNU Emacs. pdumper branch, which can allow very fast startup times."
+arch=('x86_64') # Arch Linux only. Users of derivatives are on their own.
+url="http://www.gnu.org/software/emacs/"
+license=('GPL3')
+depends=( 'alsa-lib' 'gnutls' 'libxml2' 'jansson' )
+makedepends=( 'git' )
+#######################################################################
+
+#######################################################################
+if [[ $CLANG = "YES" ]]; then
+ export CC=/usr/bin/clang ;
+ export CXX=/usr/bin/clang++ ;
+ export CPP="/usr/bin/clang -E" ;
+ export LDFLAGS+=' -fuse-ld=lld' ;
+ makedepends+=( 'clang' 'lld') ;
+fi
+
+if [[ $LTO = "YES" ]]; then
+ export CFLAGS+=" -flto"
+ export tXXFLAGS+=" -flto"
+fi
+
+if [[ $NOTKIT = "YES" ]]; then
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' );
+elif [[ $LUCID = "YES" ]]; then
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxfixes' 'lcms2' 'librsvg' 'xaw3d' );
+elif [[ $GTK2 = "YES" ]]; then
+ depends+=( 'gtk2' );
+else
+ depends+=( 'gtk3' );
+fi
+
+if [[ $GPM = "YES" ]]; then
+ depends+=( 'gpm');
+fi
+
+if [[ $M17N = "YES" ]]; then
+ depends+=( 'm17n-lib' );
+fi
+
+if [[ $OTF = "YES" ]] && [[ ! $M17N = "YES" ]]; then
+ depends+=( 'libotf' );
+fi
+
+if [[ $MAGICK = "YES" ]]; then
+ depends+=( 'libmagick6' 'libjpeg-turbo' 'giflib' );
+elif [[ ! $NOX = "YES" ]]; then
+ depends+=( 'libjpeg-turbo' 'giflib' );
+else
+ depends+=();
+fi
+
+if [[ $CAIRO = "YES" ]]; then
+ depends+=( 'cairo' );
+fi
+
+if [[ $XWIDGETS = "YES" ]]; then
+ if [[ $GTK2 = "YES" ]] || [[ $LUCID = "YES" ]] || [[ $NOTKIT = "YES" ]] || [[ $CLI = "YES" ]]; then
+ echo "";
+ echo "";
+ echo "Xwidgets support *requires* gtk+3!!!";
+ echo "";
+ echo "";
+ exit 1;
+ else
+ depends+=( 'webkit2gtk' );
+ fi
+fi
+
+if [[ $DOCS_PDF = "YES" ]]; then
+ makedepends+=( 'texlive-core' );
+fi
+#######################################################################
+
+#######################################################################
+conflicts=('emacs')
+provides=('emacs')
+source=("emacs-git::git+https://github.com/emacs-mirror/emacs.git#branch=$BRANCH"
+ pdump-patch.diff)
+md5sums=('SKIP'
+ '8769fcfd87b5ec0a0ba8d8108d09b34f')
+# If Github access is blocked for reasons, use Savannah's servers instead.
+# Edit the config file of your local repo copy as well.
+#source=("emacs-git::git://git.sv.gnu.org/emacs.git#branch=$BRANCH")
+#source=("emacs-git::git+https://git.savannah.gnu.org/emacs.git#branch=$BRANCH")
+
+if [[ $BRANCH = "master" ]]; then
+ pkgver() {
+ cd "$srcdir/emacs-git"
+
+ printf "%s.%s" \
+ "$(grep AC_INIT configure.ac | \
+ sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\?\).\+$/\1/')" \
+ "$(git rev-list --count HEAD)"
+ }
+else
+ pkgver() {
+ cd "$srcdir/emacs-git"
+
+ printf "%s.%s" \
+ "$(grep AC_INIT configure.ac | \
+ awk '{split($0,a,","); print a[2]}' | \
+ sed -e 's/\ //g' )" \
+ "$(git rev-list --count HEAD)"
+ }
+fi
+
+# There is no need to run autogen.sh after first checkout.
+# Doing so, breaks incremental compilation.
+prepare() {
+ cd "${srcdir}"
+ patch -p1 -i "pdump-patch.diff"
+ cd "$srcdir/emacs-git"
+ [[ -x configure ]] || ( ./autogen.sh git && ./autogen.sh autoconf )
+}
+
+build() {
+ cd "$srcdir/emacs-git"
+
+ local _conf=(
+ --prefix=/usr
+ --sysconfdir=/etc
+ --libexecdir=/usr/lib
+ --localstatedir=/var
+ --mandir=/usr/share/man
+ --with-gameuser=:games
+ --with-sound=alsa
+ --with-modules
+# Beware https://debbugs.gnu.org/cgi/bugreport.cgi?bug=25228
+# dconf and gconf break font settings you set in ~/.emacs.
+# If you insist you'll need to play gymnastics with
+# set-frame-font and set-menu-font. Good luck!
+ --without-gconf
+ --without-gsettings
+ )
+
+#######################################################################
+
+#######################################################################
+
+if [[ $CLANG = "YES" ]]; then
+ _conf+=(
+ '--enable-autodepend'
+ );
+fi
+
+if [[ $LTO = "YES" ]]; then
+ _conf+=(
+ '--enable-link-time-optimization'
+ );
+fi
+
+if [[ $CLI = "YES" ]]; then
+ _conf+=( '--without-x' '--with-x-toolkit=no' '--without-xft' '--without-lcms2' '--without-rsvg' );
+elif [[ $NOTKIT = "YES" ]]; then
+ _conf+=( '--with-x-toolkit=no' '--without-toolkit-scroll-bars' '--with-xft' '--without-xaw3d' );
+elif [[ $LUCID = "YES" ]]; then
+ _conf+=( '--with-x-toolkit=lucid' '--with-xft' '--with-xaw3d' );
+elif [[ $GTK2 = "YES" ]]; then
+ _conf+=( '--with-x-toolkit=gtk2' '--without-gsettings' '--without-xaw3d' );
+else
+ _conf+=( '--with-x-toolkit=gtk3' '--without-xaw3d' );
+fi
+
+if [[ ! $GPM = "YES" ]]; then
+ _conf+=( '--without-gpm' );
+fi
+
+if [[ ! $M17N = "YES" ]]; then
+ _conf+=( '--without-m17n-flt' );
+fi
+
+if [[ $MAGICK = "YES" ]]; then
+ _conf+=(
+ '--with-imagemagick'
+ );
+ export PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig
+else
+ _conf+=( '--without-imagemagick' );
+fi
+
+if [[ $CAIRO = "YES" ]]; then
+ _conf+=( '--with-cairo' );
+fi
+
+if [[ $XWIDGETS = "YES" ]]; then
+ _conf+=( '--with-xwidgets' );
+fi
+
+if [[ $NOGZ = "YES" ]]; then
+ _conf+=( '--without-compress-install' );
+fi
+#######################################################################
+
+#######################################################################
+
+ # Use gold with gcc, unconditionally.
+ #
+ if [[ ! $CLANG = "YES" ]]; then
+ export LD=/usr/bin/ld.gold
+ export LDFLAGS+=" -fuse-ld=gold";
+ fi
+
+ ./configure "${_conf[@]}"
+
+ # Using "make" instead of "make bootstrap" enables incremental
+ # compiling. Less time recompiling. Yay! But you may
+ # need to use bootstrap sometimes to unbreak the build.
+ # Just add it to the command line.
+ #
+ # Please note that incremental compilation implies that you
+ # are reusing your src directory!
+ #
+ make
+
+ # You may need to run this if 'loaddefs.el' files corrupt.
+ #cd "$srcdir/emacs-git/lisp"
+ #make autoloads
+ #cd ../
+
+ # Optional documentation formats.
+ if [[ $DOCS_HTML = "YES" ]]; then
+ make html;
+ fi
+ if [[ $DOCS_PDF = "YES" ]]; then
+ make pdf;
+ fi
+ if [[ $CHECK = "YES" ]]; then
+ make check;
+ fi
+
+}
+
+package() {
+ cd "$srcdir/emacs-git"
+
+ make DESTDIR="$pkgdir/" install
+
+ # Install optional documentation formats
+ if [[ $DOCS_HTML = "YES" ]]; then make DESTDIR="$pkgdir/" install-html; fi
+ if [[ $DOCS_PDF = "YES" ]]; then make DESTDIR="$pkgdir/" install-pdf; fi
+
+ # remove conflict with ctags package
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+
+ if [[ $NOGZ = "YES" ]]; then
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1,ctags.emacs.1};
+ else
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1.gz}
+ fi
+
+ # fix user/root permissions on usr/share files
+ find "$pkgdir"/usr/share/emacs/ | xargs chown root:root
+
+ # fix permssions on /var/games
+ mkdir -p "$pkgdir"/var/games/emacs
+ chmod 775 "$pkgdir"/var/games
+ chmod 775 "$pkgdir"/var/games/emacs
+ chown -R root:games "$pkgdir"/var/games
+
+}
+
+# vim:set ft=sh ts=2 sw=2 et:
diff --git a/pdump-patch.diff b/pdump-patch.diff
new file mode 100644
index 000000000000..673f9c3ca444
--- /dev/null
+++ b/pdump-patch.diff
@@ -0,0 +1,11 @@
+--- src/emacs-git/src/pdumper.c 2018-07-06 08:37:15.740237090 +0200
++++ pdumper.c 2018-07-06 09:12:58.966935413 +0200
+@@ -136,7 +136,7 @@
+ {
+ void *mem;
+ int sz;
+-} remembered_data[32];
++} remembered_data[64];
+ static int nr_remembered_data = 0;
+
+ typedef int32_t dump_off;