summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-12 07:24:47 +0200
committersballert2018-09-12 07:24:47 +0200
commitdc9ccfa09f1d3e1b4074bb6d0dd3b995eb1616c6 (patch)
tree8f89868fc62f762ba9df04e4b148b9a743ad3510
downloadaur-dc9ccfa09f1d3e1b4074bb6d0dd3b995eb1616c6.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a01e950167d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-persp-mode-git
+ pkgdesc = named perspectives(set of buffers/window configs) for emacs
+ pkgver = r468.cc1d16a
+ pkgrel = 1
+ url = https://github.com/Bad-ptr/persp-mode.el
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-persp-mode
+ conflicts = emacs-persp-mode
+ source = git+https://github.com/Bad-ptr/persp-mode.el.git
+ sha256sums = SKIP
+
+pkgname = emacs-persp-mode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f6916166703
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="Bad-ptr"
+_gitrepo="persp-mode.el"
+
+pkgname=emacs-persp-mode-git
+pkgver=r468.cc1d16a
+pkgrel=1
+pkgdesc="named perspectives(set of buffers/window configs) for emacs"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-persp-mode')
+conflicts=('emacs-persp-mode')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/persp-mode/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/persp-mode/
+}