summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhamki2023-08-13 03:32:24 +0800
committerhamki2023-08-13 03:32:24 +0800
commit0dac4e97be3c5ccea9b5f4c53853e99deb308774 (patch)
tree6ecaeb2a3e7357368df157004cac69b1270fe6e5
parent410117448451f7aa9c7292721ecd405bbc006c55 (diff)
downloadaur-emacs-pg.tar.gz
fix license, new offical upstream, version change
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9afe3891b6f1..8275cd30e99e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = emacs-pg
- pkgdesc = pg.el is an Emacs Lisp interface for PostgreSQL
- pkgver = 1.2.4
+ pkgdesc = Emacs Lisp socket-level interface to the PostgreSQL RDBMS
+ pkgver = 0.20
pkgrel = 1
- url = https://github.com/cbbrowne/pg.el
+ url = https://github.com/emarsden/pg-el
arch = any
- license = GPL3
+ license = GPL2
depends = emacs
- source = emacs-pg::git+https://github.com/cbbrowne/pg.el
- sha256sums = SKIP
+ source = emacs-pg-0.20.tar.gz::https://github.com/emarsden/pg-el/archive/v0.20.tar.gz
+ sha256sums = 8cc4146d364e45bfaf9a785a1401151dec3c64d8d0584179a9af18868c71360e
pkgname = emacs-pg
diff --git a/PKGBUILD b/PKGBUILD
index 7efad3c67a1b..fe8230bf8ad4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: hamki <hamki.do2000@gmail.com>
+# Maintainer: hamki <me@hamki.org>
pkgname=emacs-pg
-pkgver=1.2.4
+pkgver=0.20
pkgrel=1
-pkgdesc="pg.el is an Emacs Lisp interface for PostgreSQL"
-url="https://github.com/cbbrowne/pg.el"
+pkgdesc="Emacs Lisp socket-level interface to the PostgreSQL RDBMS"
+url="https://github.com/emarsden/pg-el"
arch=('any')
-license=('GPL3')
+license=('GPL2')
depends=('emacs')
makedepends=()
provides=()
conflicts=()
-source=('emacs-pg::git+https://github.com/cbbrowne/pg.el')
-sha256sums=('SKIP')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/emarsden/pg-el/archive/v${pkgver}.tar.gz")
+sha256sums=('8cc4146d364e45bfaf9a785a1401151dec3c64d8d0584179a9af18868c71360e')
build() {
- cd "${srcdir}/emacs-pg"
+ cd "${srcdir}/pg-el-${pkgver}"
emacs -Q -batch -L . -f batch-byte-compile *.el
}
package() {
- cd "${srcdir}/emacs-pg"
+ cd "${srcdir}/pg-el-${pkgver}"
install -d "${pkgdir}/usr/share/emacs/site-lisp/emacs-pg"
install -m644 *.el* "${pkgdir}/usr/share/emacs/site-lisp/emacs-pg/"
}