summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhamki2021-06-18 18:44:32 +0800
committerhamki2021-06-18 18:44:32 +0800
commit410117448451f7aa9c7292721ecd405bbc006c55 (patch)
tree4d953a0a2d26e385dd49a62db024179264c6e2b0
downloadaur-410117448451f7aa9c7292721ecd405bbc006c55.tar.gz
init
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9afe3891b6f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = emacs-pg
+ pkgdesc = pg.el is an Emacs Lisp interface for PostgreSQL
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://github.com/cbbrowne/pg.el
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = emacs-pg::git+https://github.com/cbbrowne/pg.el
+ sha256sums = SKIP
+
+pkgname = emacs-pg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7efad3c67a1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: hamki <hamki.do2000@gmail.com>
+
+pkgname=emacs-pg
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="pg.el is an Emacs Lisp interface for PostgreSQL"
+url="https://github.com/cbbrowne/pg.el"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=()
+provides=()
+conflicts=()
+source=('emacs-pg::git+https://github.com/cbbrowne/pg.el')
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/emacs-pg"
+ emacs -Q -batch -L . -f batch-byte-compile *.el
+ }
+
+package() {
+ cd "${srcdir}/emacs-pg"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/emacs-pg"
+ install -m644 *.el* "${pkgdir}/usr/share/emacs/site-lisp/emacs-pg/"
+}