summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-06-03 14:59:24 -0400
committerAlex Whitt2017-06-03 14:59:24 -0400
commit1c1a181d41bcb552f3d61763719bfaef9e7f4960 (patch)
tree6f46ef59a91195315b4ae748beb78572783496fd
downloadaur-1c1a181d41bcb552f3d61763719bfaef9e7f4960.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcbd45b9dd1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Jun 3 18:58:57 UTC 2017
+pkgbase = emacs-pkg-info
+ pkgdesc = Provide information about Emacs packages
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://github.com/lunaryorn/pkg-info.el
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-epl
+ source = emacs-pkg-info-0.6.tar.gz::https://github.com/lunaryorn/pkg-info.el/archive/0.6.tar.gz
+ sha256sums = a5e5123f96bfa635c67ea64cf8df2b3a29e448f6ec2116de13a0d65af494c1bf
+
+pkgname = emacs-pkg-info
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3868e894441c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=pkg-info.el
+_pkgmaintainer=lunaryorn
+_pkgdestdirname=pkg-info
+_versionprefix=
+pkgver=0.6
+pkgrel=1
+pkgdesc="Provide information about Emacs packages"
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs' 'emacs-epl')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('a5e5123f96bfa635c67ea64cf8df2b3a29e448f6ec2116de13a0d65af494c1bf')
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}