summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuki-san2015-10-05 17:55:32 +0900
committeryuki-san2015-10-05 17:55:32 +0900
commitd555b4d8b297c8c827b5f3e3e6047d7e3b0a4965 (patch)
tree753fab85a7c85912231cbca8db53b1b37f6e7b65
downloadaur-d555b4d8b297c8c827b5f3e3e6047d7e3b0a4965.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD32
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbe3e4ba64a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = emacs-popup-el
+ pkgdesc = A visual popup user interface library for Emacs
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = https://github.com/auto-complete/popup-el
+ arch = any
+ license = GPL
+ makedepends = emacs
+ makedepends = cask
+ depends = emacs
+ source = popup-el-0.5.3.tar.gz::https://github.com/auto-complete/popup-el/archive/v0.5.3.tar.gz
+ md5sums = 7dedfb1b46cc2f88a7004391f3f5d314
+
+pkgname = emacs-popup-el
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ccbad1e93c9d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+emacs-popup-el-*.pkg.tar.xz
+popup-el-*.tar.gz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..445a41c66894
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: yuki-san <yuki.from.akita@gmail.com>
+
+pkgname=emacs-popup-el
+pkgver=0.5.3
+pkgrel=1
+pkgdesc='A visual popup user interface library for Emacs'
+arch=('any')
+url="https://github.com/auto-complete/popup-el"
+license=('GPL')
+depends=('emacs')
+makedepends=('emacs' 'cask')
+source=(${pkgname#emacs-}-${pkgver}.tar.gz::"https://github.com/auto-complete/popup-el/archive/v0.5.3.tar.gz")
+md5sums=('7dedfb1b46cc2f88a7004391f3f5d314')
+
+_elfile=popup
+
+build() {
+ cd "$srcdir/${pkgname#emacs-}-${pkgver}"
+ emacs -q -batch -f batch-byte-compile "$_elfile".el
+}
+
+package() {
+ cd "$srcdir/${pkgname#emacs-}-${pkgver}"
+ install -d -m 755 "$pkgdir"/usr/share/emacs/site-lisp
+ install -c -m 644 "$_elfile".el "$pkgdir"/usr/share/emacs/site-lisp
+ install -c -m 644 "$_elfile".elc "$pkgdir"/usr/share/emacs/site-lisp
+
+ install -d -m 755 "$pkgdir"/usr/share/doc/${pkgname}
+ install -c -m 644 README.md "$pkgdir"/usr/share/doc/${pkgname}
+}
+
+# vim:set ts=2 sw=2 et: