summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-11 12:52:16 -0400
committerAlex Whitt2017-05-11 12:52:16 -0400
commit8898954b6dc6fa9ff791a5d1d61aa9b940ab1cd4 (patch)
treecc139fc06c714646b9c62ae2762f372aa6db1743
downloadaur-emacs-popwin.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-popwin.install21
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c45487936122
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu May 11 16:51:27 UTC 2017
+pkgbase = emacs-popwin
+ pkgdesc = Popup Window Manager for Emacs
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/m2ym/popwin-el
+ install = emacs-popwin.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = emacs-popwin-1.0.0.tar.gz::https://github.com/m2ym/popwin-el/archive/v1.0.0.tar.gz
+ sha256sums = 4f09c3cf6294dd6cb57751f9911c59d9367b25c8748689e7748c464f1abd46aa
+
+pkgname = emacs-popwin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c517cdda67b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=popwin-el
+_pkgmaintainer=m2ym
+_pkgdestdirname=popwin
+_versionprefix=v
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Popup Window Manager for Emacs"
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('4f09c3cf6294dd6cb57751f9911c59d9367b25c8748689e7748c464f1abd46aa')
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}
diff --git a/emacs-popwin.install b/emacs-popwin.install
new file mode 100644
index 000000000000..6aeef8eda01b
--- /dev/null
+++ b/emacs-popwin.install
@@ -0,0 +1,21 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'popwin)
+(popwin-mode 1)
+
+==> Or do the above with use-package:
+
+(use-package popwin
+ :config
+ (popwin-mode 1))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}