summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Jost2014-04-14 10:28:32 +0200
committerThomas Jost2014-04-14 10:29:17 +0200
commit141ca3b4b6dc55d2bd192f062ee68b0f27516b86 (patch)
tree322321b2528e00d69e2cfc06bc18a471400a44ad
parentcf19d5736816447e37fbec99dc9e61118746f636 (diff)
downloadaur-141ca3b4b6dc55d2bd192f062ee68b0f27516b86.tar.gz
Version bump
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
-rw-r--r--emacs.desktop12
-rw-r--r--emacs.install12
4 files changed, 33 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdf6b9300726..9bacee4cbf0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-pretest
pkgdesc = The extensible, customizable, self-documenting real-time display editor -- pretest version
- pkgver = 24.1rc
+ pkgver = 24.3.90
pkgrel = 1
url = http://www.gnu.org/software/emacs/emacs.html
install = emacs.install
@@ -11,23 +11,21 @@ pkgbase = emacs-pretest
depends = gpm
depends = giflib
depends = libxpm
- depends = gtk2
+ depends = libotf
+ depends = m17n-lib
+ depends = gtk3
depends = hicolor-icon-theme
depends = gconf
depends = desktop-file-utils
depends = alsa-lib
- provides = emacs=24.1
+ depends = imagemagick
+ depends = gnutls
+ provides = emacs==24.3.90
conflicts = emacs
- conflicts = emacs-nox
- conflicts = emacs-bzr
- conflicts = emacs-git
- conflicts = emacs-cvs
- source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-24.1-rc.tar.gz
- source = emacs.desktop
- md5sums = 07c36f4e3fa3394ae5a6b513800bc976
- md5sums = 8af038d2ba4561271e935bb444ceb4e3
- sha256sums = 83d4ea3cf59be4d672b59fa2944f7c6ab2c3790ab8644b9e5673bdfdcda20cbf
- sha256sums = dba3652cdfd4193d264cf9ebafcef3e6be4af3f83bdf187d421f8e4c07f94b39
+ source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-24.3.90.tar.xz
+ source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-24.3.90.tar.xz.sig
+ md5sums = e13c66edb07327c07f0aacce5f70c74b
+ md5sums = SKIP
pkgname = emacs-pretest
diff --git a/PKGBUILD b/PKGBUILD
index 27fa7f202bbc..9f1d128b983c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,44 @@
# Maintainer: Thomas Jost <schnouki@schnouki.net>
# Contributor: Juergen Hoetzel <juergen@archlinux.org>
# Contributor: Renchi Raju <renchi@green.tam.uiuc.edu>
+
pkgname=emacs-pretest
_pkgname=emacs
-pkgver=24.1rc
-_pkgver=24.1
+pkgver=24.3.90
pkgrel=1
pkgdesc="The extensible, customizable, self-documenting real-time display editor -- pretest version"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'gtk2' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib')
-provides=("emacs=$_pkgver")
-conflicts=("emacs" "emacs-nox" "emacs-bzr" "emacs-git" "emacs-cvs")
+depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk3' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib' 'imagemagick' 'gnutls')
install=emacs.install
-source=(ftp://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$_pkgver-rc.tar.gz emacs.desktop)
-md5sums=('07c36f4e3fa3394ae5a6b513800bc976'
- '8af038d2ba4561271e935bb444ceb4e3')
-sha256sums=('83d4ea3cf59be4d672b59fa2944f7c6ab2c3790ab8644b9e5673bdfdcda20cbf'
- 'dba3652cdfd4193d264cf9ebafcef3e6be4af3f83bdf187d421f8e4c07f94b39')
+provides=("emacs==$pkgver")
+conflicts=('emacs')
+source=(ftp://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$pkgver.tar.xz{,.sig})
+md5sums=('e13c66edb07327c07f0aacce5f70c74b'
+ 'SKIP')
build() {
- cd "$srcdir"/$_pkgname-$_pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --localstatedir=/var --with-x-toolkit=gtk --with-xft
- # Alternatives: --with-x-toolkit=lucid, --with-x-toolkit=gtk3
+ cd "$srcdir"/$_pkgname-$pkgver
+ ac_cv_lib_gif_EGifPutExtensionLast=yes ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --with-x-toolkit=gtk3 --with-xft
make
}
package() {
- cd "$srcdir"/$_pkgname-$_pkgver
+ cd "$srcdir"/$_pkgname-$pkgver
make DESTDIR="$pkgdir" install
# remove conflict with ctags package
mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
- mv "$pkgdir"/usr/share/man/man1/{ctags.1,ctags.emacs.1}.gz
- # fix all the 777 perms on directories
- find "$pkgdir"/usr/share/emacs/$_pkgver -type d -exec chmod 755 {} \;
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+ # remove conflict with texinfo
+ rm "$pkgdir"/usr/share/info/info.info.gz
# fix user/root permissions on usr/share files
- find "$pkgdir"/usr/share/emacs/$_pkgver -exec chown root:root {} \;
+ find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
# fix perms on /var/games
chmod 775 "$pkgdir"/var/games
chmod 775 "$pkgdir"/var/games/emacs
chmod 664 "$pkgdir"/var/games/emacs/*
chown -R root:games "$pkgdir"/var/games
-
- # fix FS#9253
- mkdir -p "$pkgdir"/usr/share/pixmaps "$pkgdir"/usr/share/applications
- install -D -m644 "$srcdir"/$_pkgname.desktop "$pkgdir"/usr/share/applications
- ln -s ../emacs/$_pkgver/etc/images/icons/hicolor/48x48/apps/emacs.png "$pkgdir"/usr/share/pixmaps/emacs-icon.png
}
diff --git a/emacs.desktop b/emacs.desktop
deleted file mode 100644
index 71b3d5bbf33b..000000000000
--- a/emacs.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Name=Emacs Text Editor
-Name[de]=Emacs Texteditor
-GenericName=Text Editor
-Comment=Edit text
-MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
-Exec=emacs %f
-Icon=emacs-icon
-Type=Application
-Terminal=false
-Categories=Development;TextEditor;
-StartupWMClass=Emacs
diff --git a/emacs.install b/emacs.install
index d84f1de14449..6712f44bab84 100644
--- a/emacs.install
+++ b/emacs.install
@@ -1,11 +1,11 @@
ICON_PATH=usr/share/icons/hicolor
INFO_DIR=usr/share/info
-INFO_FILES=(ada-mode auth autotype calc ccmode cl dbus dired-x ebrowse
-ede ediff edt efaq eieio eintr elisp emacs emacs-mime epa erc eshell eudc flymake
-forms gnus idlwave info mairix-el message mh-e newsticker nxml-mode
+INFO_FILES=(ada-mode auth autotype bovine calc ccmode cl dbus dired-x ebrowse
+ede ediff edt efaq eieio eintr elisp emacs emacs-gnutls emacs-mime epa erc ert eshell eudc flymake
+forms gnus htmlfontify idlwave mairix-el message mh-e newsticker nxml-mode
org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve smtpmail
-speedbar tramp url vip viper widget woman)
+speedbar srecode tramp url vip viper widget wisent woman)
post_install() {
gtk-update-icon-cache -q -t -f ${ICON_PATH}
@@ -13,7 +13,7 @@ post_install() {
[[ -x usr/bin/install-info ]] || return 0
for f in ${INFO_FILES[@]}; do
- install-info ${INFO_DIR}/$f.gz ${INFO_DIR}/dir 2> /dev/null
+ install-info ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
done
}
@@ -27,6 +27,6 @@ pre_remove() {
[[ -x usr/bin/install-info ]] || return 0
for f in ${INFO_FILES[@]}; do
- install-info --delete ${INFO_DIR}/$f.gz ${INFO_DIR}/dir 2> /dev/null
+ install-info --delete ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
done
}