summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.A. López-Valencia2017-01-01 14:38:03 -0500
committerP.A. López-Valencia2017-01-01 14:38:03 -0500
commit20de845f1c01501e3d5a113793d803d7daa499d6 (patch)
tree328c04dad4149a55511edaecc670e45b7bf66e6e
parent322d214e531588ba72daaba501c7e4d3dfac251a (diff)
downloadaur-20de845f1c01501e3d5a113793d803d7daa499d6.tar.gz
25.1.91
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--emacs-pretest.install33
3 files changed, 25 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8801c83f658b..927c34ef72af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,31 @@
pkgbase = emacs-pretest
pkgdesc = The extensible, customizable, self-documenting real-time display editor -- pretest version
- pkgver = 25.1.90
+ pkgver = 25.1.91
pkgrel = 1
url = http://www.gnu.org/software/emacs/emacs.html
- install = emacs-pretest.install
arch = i686
arch = x86_64
license = GPL3
- depends = gtk3
+ depends = librsvg
depends = gpm
depends = giflib
+ depends = libxpm
+ depends = libotf
depends = m17n-lib
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = gconf
depends = desktop-file-utils
depends = alsa-lib
depends = imagemagick
- depends = zlib
+ depends = gnutls
provides = emacs
conflicts = emacs
- source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-25.1.90.tar.xz
- source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-25.1.90.tar.xz.sig
- sha512sums = 9d20f83d62598b74466e2b12bd09388b27099708aba831806dc5c0710071499b1796b3e986e0fa35384873d0f5faa5dec2866dce297a7cc7136a77a2bb1e0bcd
+ source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-25.1.91.tar.xz
+ source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-25.1.91.tar.xz.sig
+ validpgpkeys = B29426DEFB07724C3C35E5D36592E9A3A0B0F199
+ validpgpkeys = 28D3BED851FDF3AB57FEF93C233587A47C207910
+ sha512sums = 09ecd852e6bf523c8ae7835b496fbd53c0dafeccaa5c3319e9a7f664be0816fdd5acbe9c5267f2dab2912aff9656448ac53f6b22329aea15d3e3af41c04806ff
sha512sums = SKIP
pkgname = emacs-pretest
diff --git a/PKGBUILD b/PKGBUILD
index 92ebcf2ba728..fb38258e75d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,61 +5,48 @@
pkgname=emacs-pretest
_pkgname=emacs
-pkgver=25.1.90
+pkgver=25.1.91
pkgrel=1
pkgdesc="The extensible, customizable, self-documenting real-time display editor -- pretest version"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('gtk3' 'gpm' 'giflib' 'm17n-lib' 'desktop-file-utils' 'alsa-lib' 'imagemagick' 'zlib')
-install=$pkgname.install
+depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk3' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib' 'imagemagick' 'gnutls')
provides=('emacs')
conflicts=('emacs')
source=(ftp://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$pkgver.tar.xz{,.sig})
-sha512sums=('9d20f83d62598b74466e2b12bd09388b27099708aba831806dc5c0710071499b1796b3e986e0fa35384873d0f5faa5dec2866dce297a7cc7136a77a2bb1e0bcd'
+sha512sums=('09ecd852e6bf523c8ae7835b496fbd53c0dafeccaa5c3319e9a7f664be0816fdd5acbe9c5267f2dab2912aff9656448ac53f6b22329aea15d3e3af41c04806ff'
'SKIP')
-validpgkkeys=('28D3BED851FDF3AB57FEF93C233587A47C207910')
+validpgpkeys=('B29426DEFB07724C3C35E5D36592E9A3A0B0F199' '28D3BED851FDF3AB57FEF93C233587A47C207910')
build() {
cd "$srcdir"/$_pkgname-$pkgver
-
- # Avoid hardening-wrapper
export PATH=$(echo "$PATH" | sed 's!/usr/lib/hardening-wrapper/bin!!g')
-
+ export REL_ALLOC=no
local confopts=(--prefix=/usr
--sysconfdir=/etc
--libexecdir=/usr/lib
--localstatedir=/var
- --without-gconf
- --with-sound=alsa
--with-x-toolkit=gtk3
- --with-game-user=:games
- --with-modules)
- ./configure "${confopts[@]}"
+ --with-xft)
+ ac_cv_lib_gif_EGifPutExtensionLast=yes ./configure "${confopts[@]}"
make
}
package() {
- cd "$srcdir"/$_pkgname-$pkgver
-
- # Avoid hardening-wrapper
- export PATH=$(echo "$PATH" | sed 's!/usr/lib/hardening-wrapper/bin!!g')
-
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
# remove conflict with ctags package
mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
- mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1.gz}
-
- # remove conflict with texinfo
- rm "$pkgdir"/usr/share/info/info.info.gz
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
- # fix ownership on usr/share files
+ # fix user/root permissions on usr/share files
find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
-
- # fix access permissions on /var/games
+ # fix perms on /var/games
chmod 775 "$pkgdir"/var/games
chmod 775 "$pkgdir"/var/games/emacs
chmod 664 "$pkgdir"/var/games/emacs/*
chown -R root:games "$pkgdir"/var/games
}
+
diff --git a/emacs-pretest.install b/emacs-pretest.install
deleted file mode 100644
index d2bd7d366826..000000000000
--- a/emacs-pretest.install
+++ /dev/null
@@ -1,33 +0,0 @@
-ICON_PATH=usr/share/icons/hicolor
-INFO_DIR=usr/share/info
-
-INFO_FILES=(ada-mode auth autotype bovine calc ccmode cl dbus dired-x
- ebrowse ede ediff edt efaq eieio eintr elisp emacs emacs-gnutls
- emacs-mime epa erc ert eshell eudc flymake forms gnus htmlfontify
- idlwave mairix-el message mh-e newsticker nxml-mode org pcl-cvs pgg
- rcirc reftex remember sasl sc semantic ses sieve smtpmail speedbar
- srecode tramp url vip viper widget wisent woman)
-
-post_install() {
- gtk-update-icon-cache -q -t -f ${ICON_PATH}
- update-desktop-database -q
-
- [[ -x usr/bin/install-info ]] || return 0
- for f in "${INFO_FILES[@]}"; do
- install-info ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- gtk-update-icon-cache -q -t -f ${ICON_PATH}
- update-desktop-database -q
-
- [[ -x usr/bin/install-info ]] || return 0
- for f in "${INFO_FILES[@]}"; do
- install-info --delete ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
- done
-}