summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2019-08-26 14:22:48 -0500
committerPedro A. López-Valencia2019-08-26 14:22:48 -0500
commit9feb83af7b428ef37b2d6ebdcbc396225959b7df (patch)
tree2d5315bf7506a7f745f617f9e0cc21d6c8e4da86
parentac046e0af6ed047c62ddfcb85354a011b9b737e4 (diff)
downloadaur-9feb83af7b428ef37b2d6ebdcbc396225959b7df.tar.gz
26.3-rc12
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b4c9828ffc8..1716f8ccd9ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-pretest
pkgdesc = The extensible, customizable, self-documenting real-time display editor -- pretest version
- pkgver = 26.2.90
- pkgrel = 2
+ pkgver = 26.3
+ pkgrel = 0.1
url = http://www.gnu.org/software/emacs/emacs.html
arch = x86_64
license = GPL3
@@ -9,15 +9,14 @@ pkgbase = emacs-pretest
depends = m17n-lib
depends = gtk3
depends = libmagick6
- depends = gnutls
provides = emacs
conflicts = emacs
- source = https://alpha.gnu.org/gnu/emacs/pretest/emacs-26.2.90.tar.xz
- source = https://alpha.gnu.org/gnu/emacs/pretest/emacs-26.2.90.tar.xz.sig
+ source = https://alpha.gnu.org/gnu/emacs/pretest/emacs-26.3-rc1.tar.xz
+ source = https://alpha.gnu.org/gnu/emacs/pretest/emacs-26.3-rc1.tar.xz.sig
validpgpkeys = B29426DEFB07724C3C35E5D36592E9A3A0B0F199
validpgpkeys = 28D3BED851FDF3AB57FEF93C233587A47C207910
validpgpkeys = D405AA2C862C54F17EEE6BE0E8BCD7866AFCF978
- sha512sums = 66e53ae2a6d89505111e7bc9b7a6e6324a9a5577d1ad8905244dbc8619b21ea410b20bd8bab0442ec226f7a0d5f2292e01171189517736e4fa5e0e15eba51074
+ sha512sums = 4d5a4319253afb081e105a3697eb6eeb8d8a0da18cd41346e376ca5af1e180a26e641f76c64fad1b0253168f14a511f0a4d9d4141524fb1cf4d04f25b05a76e9
sha512sums = SKIP
pkgname = emacs-pretest
diff --git a/PKGBUILD b/PKGBUILD
index 2ff4e36281a1..24dd8818d57c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,26 @@
# Contributor: Renchi Raju <renchi@green.tam.uiuc.edu>
pkgname=emacs-pretest
-pkgver=26.2.90
_pkgname=emacs
-_pkgver=$pkgver
-pkgrel=2
+pkgver=26.3
+_pkgver=26.3-rc1
+pkgrel=0.1
pkgdesc="The extensible, customizable, self-documenting real-time display editor -- pretest version"
arch=('x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('gpm' 'm17n-lib' 'gtk3' 'libmagick6' 'gnutls')
+depends=('gpm' 'm17n-lib' 'gtk3' 'libmagick6')
provides=('emacs')
conflicts=('emacs')
-source=(https://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$pkgver.tar.xz{,.sig})
-sha512sums=('66e53ae2a6d89505111e7bc9b7a6e6324a9a5577d1ad8905244dbc8619b21ea410b20bd8bab0442ec226f7a0d5f2292e01171189517736e4fa5e0e15eba51074'
+source=(https://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$_pkgver.tar.xz{,.sig})
+sha512sums=('4d5a4319253afb081e105a3697eb6eeb8d8a0da18cd41346e376ca5af1e180a26e641f76c64fad1b0253168f14a511f0a4d9d4141524fb1cf4d04f25b05a76e9'
'SKIP')
validpgpkeys=('B29426DEFB07724C3C35E5D36592E9A3A0B0F199' '28D3BED851FDF3AB57FEF93C233587A47C207910' 'D405AA2C862C54F17EEE6BE0E8BCD7866AFCF978')
build() {
- cd "$srcdir"/$_pkgname-$_pkgver
+ cd "$srcdir"/$_pkgname-$pkgver
-# Else imagemagick is not detected.
+# Force imagemagick6 detection.
export PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig
local confopts=(
@@ -34,11 +34,13 @@ export PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig
--with-gameuser=root:games
--with-x-toolkit=gtk3
--with-xft
+ --with-modules
+ --without-compress-install
# Beware https://debbugs.gnu.org/cgi/bugreport.cgi?bug=25228
# dconf and gconf break font settings set in ~/.emacs
# If you insist you'll need to play gymnastics with
# set-frame-font and set-menu-font. Good luck!
-# Psst! Seems to be fixed in master. Try emacs-git.
+# Seems to be fixed in master. Try emacs-git.
--without-gsettings
--without-gconf
)
@@ -47,12 +49,13 @@ export PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig
}
package() {
- cd "$srcdir"/$_pkgname-$_pkgver
+ cd "$srcdir"/$_pkgname-$pkgver
make DESTDIR="$pkgdir" install
# remove conflict with ctags package
mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
- mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+ #mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1,ctags.emacs.1}
# fix user/root permissions on usr/share files
find "$pkgdir"/usr/share/emacs/ | xargs chown root:root