summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-08-25 17:11:40 +0200
committerhaawda2018-08-25 17:11:40 +0200
commit9b1bbfa2ba7be3dad80d09601aca2d7e6af06fc1 (patch)
tree90da1d8d0ec3739f6c5c3b80835843e9c2152d22
parent0b90837abd8b0d43ca9a5ddfb74c3921b7ed56e3 (diff)
downloadaur-9b1bbfa2ba7be3dad80d09601aca2d7e6af06fc1.tar.gz
adopted
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2fedd717ba9..a31a01ea16c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Apr 27 19:46:13 UTC 2017
pkgbase = emacs-python-environment
pkgdesc = Python virtualenv API for Emacs Lisp
pkgver = 0.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tkf/emacs-python-environment
arch = any
license = GPL3
@@ -11,8 +9,8 @@ pkgbase = emacs-python-environment
depends = emacs
depends = emacs-deferred
provides = emacs-python-environment
- source = https://github.com/tkf/emacs-python-environment/archive/0.0.2.tar.gz
- sha256sums = SKIP
+ source = emacs-python-environment-0.0.2.tar.gz::https://github.com/tkf/emacs-python-environment/archive/0.0.2.tar.gz
+ sha256sums = 8855d036ee858b8cfebf02f003a042dc1c7f4b8b00bf4c103cb12668b7fa3146
pkgname = emacs-python-environment
diff --git a/PKGBUILD b/PKGBUILD
index de46cc74410c..12d9fbf2bc97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-python-environment
pkgver=0.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Python virtualenv API for Emacs Lisp"
url="https://github.com/tkf/emacs-python-environment"
arch=('any')
@@ -10,16 +11,16 @@ license=('GPL3')
depends=('emacs' 'emacs-deferred')
makedepends=('git')
provides=('emacs-python-environment')
-source=("https://github.com/tkf/emacs-python-environment/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/tkf/emacs-python-environment/archive/${pkgver}.tar.gz")
+sha256sums=('8855d036ee858b8cfebf02f003a042dc1c7f4b8b00bf4c103cb12668b7fa3146')
build() {
- cd "${srcdir}/emacs-python-environment-${pkgver}"
+ cd emacs-python-environment-${pkgver}
emacs -q --no-splash -batch -L . -f batch-byte-compile python-environment*.el
}
package() {
- cd "${srcdir}/emacs-python-environment-${pkgver}"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/python-environment"
- install -m644 python-environment*.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/python-environment/"
-} \ No newline at end of file
+ cd emacs-python-environment-${pkgver}
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/python-environment
+ install -m644 python-environment*.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/python-environment/
+}