summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-30 16:53:51 -0400
committerAlex Whitt2017-05-30 16:53:51 -0400
commit2190508acff17e02fcf0b2190fa1d18287daf765 (patch)
treec64f47486aecb6b2ed59e785d99b1a742af6f6a8
downloadaur-2190508acff17e02fcf0b2190fa1d18287daf765.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-pyvenv.install18
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edd7dd3c2a3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue May 30 20:51:53 UTC 2017
+pkgbase = emacs-pyvenv
+ pkgdesc = Python virtual environment interface for Emacs
+ pkgver = 1.10
+ pkgrel = 1
+ url = https://github.com/jorgenschaefer/pyvenv
+ install = emacs-pyvenv.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = emacs-pyvenv-1.10.tar.gz::https://github.com/jorgenschaefer/pyvenv/archive/v1.10.tar.gz
+ sha256sums = 915798ce764c0d3fd587ed501a26e5361f5a7dedcab85cddc7dfb2091704de5d
+
+pkgname = emacs-pyvenv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f08861ea214e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=pyvenv
+_pkgmaintainer=jorgenschaefer
+_pkgdestdirname=pyvenv
+_versionprefix=v
+pkgver=1.10
+pkgrel=1
+pkgdesc="Python virtual environment interface for Emacs"
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('915798ce764c0d3fd587ed501a26e5361f5a7dedcab85cddc7dfb2091704de5d')
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}
diff --git a/emacs-pyvenv.install b/emacs-pyvenv.install
new file mode 100644
index 000000000000..d44452b749cd
--- /dev/null
+++ b/emacs-pyvenv.install
@@ -0,0 +1,18 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the library:
+
+(require 'pyvenv)
+
+==> Or, with use-package:
+
+(use-package pyvenv)
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}