summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-08-19 10:14:02 +0200
committerhaawda2018-08-19 10:14:02 +0200
commitc2f75c15f12b5dcb269ae6c7e6883dcf34cea573 (patch)
tree8dba25f309a0251bf821b99e8898a213ff27e79e
parent5c5b8f58f7ba160b0185ef2ad227579ccceec522 (diff)
downloadaur-c2f75c15f12b5dcb269ae6c7e6883dcf34cea573.tar.gz
adopted and updated
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a6c65080b02..bc6a4094c6c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Tue Apr 25 17:32:20 UTC 2017
pkgbase = emacs-s
pkgdesc = The long lost Emacs string manipulation library.
- pkgver = 1.11.0
+ pkgver = 1.12.0
pkgrel = 1
url = https://github.com/magnars/s.el
arch = any
license = GPL3
depends = emacs
- source = https://github.com/magnars/s.el/archive/1.11.0.tar.gz
- sha256sums = SKIP
+ source = emacs-s-1.12.0.tar.gz::https://github.com/magnars/s.el/archive/1.12.0.tar.gz
+ md5sums = 5bbfc45a9360ef6def7037af3ca887b7
pkgname = emacs-s
diff --git a/PKGBUILD b/PKGBUILD
index 46574bc69c22..a0b2f0b50603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-s
-pkgver=1.11.0
+pkgver=1.12.0
pkgrel=1
pkgdesc="The long lost Emacs string manipulation library."
-arch=(any)
+arch=('any')
url="https://github.com/magnars/s.el"
license=('GPL3')
depends=('emacs')
-source=("https://github.com/magnars/s.el/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/magnars/s.el/archive/$pkgver.tar.gz")
+md5sums=('5bbfc45a9360ef6def7037af3ca887b7')
build() {
- cd "${srcdir}/s.el-${pkgver}"
+ cd "$srcdir"/s.el-$pkgver
emacs -Q -batch -L . -f batch-byte-compile *.el
}
package() {
- cd "${srcdir}/s.el-${pkgver}"
- mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/s/"
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/s/"
+ cd "$srcdir"/s.el-$pkgver
+ mkdir -p "$pkgdir"/usr/share/emacs/site-lisp/s/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/s/
}