summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-03-12 20:28:11 +0100
committerhaawda2019-03-12 20:28:11 +0100
commita20baca8e6339fdf2831af51c6606008b3aa0f83 (patch)
tree1b0a778d62f19d5805e9dc9e1a86a625173a97b0
parent9e6d23aad4923cd325a04b77b718a8a906b28850 (diff)
downloadaur-a20baca8e6339fdf2831af51c6606008b3aa0f83.tar.gz
adopt and change pkgver function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdfcab14be3d..5ba6c5e2df44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-s-git
pkgdesc = The long lost Emacs string manipulation library.
- pkgver = r258.03410e6
+ pkgver = 1.12.0r10.g03410e6
pkgrel = 1
url = https://github.com/magnars/s.el
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index f9e9f6d72029..8e97925bcd86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: sballert <sballert@posteo.de>
+# Contributor: sballert <sballert@posteo.de>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
_gituser="magnars"
_gitrepo="s.el"
pkgname=emacs-s-git
-pkgver=r258.03410e6
+pkgver=1.12.0r10.g03410e6
pkgrel=1
pkgdesc="The long lost Emacs string manipulation library."
url="https://github.com/${_gituser}/${_gitrepo}"
@@ -19,7 +20,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$_gitrepo"
- printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ git describe --tags --long | sed 's+-+r+'|tr - .
}
build() {
@@ -29,6 +30,6 @@ build() {
package() {
cd "$_gitrepo"
- install -d "$pkgdir"/usr/share/emacs/site-lisp/s/
- install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/s/
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/
}