summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2016-10-15 16:28:59 +0200
committerStefan Husmann2016-10-15 16:28:59 +0200
commit7877305d00ece115639c3918dcd23d570566da7e (patch)
tree8f51db2225c951f0eeef551e1fb4253a174321e2
downloadaur-7877305d00ece115639c3918dcd23d570566da7e.tar.gz
initial upload
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78392f79b9f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = emacs-showtip
+ pkgdesc = An extension for emacs to show tip at curser
+ pkgver = 0.01
+ pkgrel = 1
+ url = https://www.emacswiki.org/emacs/showtip.el
+ arch = any
+ license = GPL
+ depends = emacs
+ source = https://www.emacswiki.org/emacs/download/showtip.el
+ md5sums = 9f23b6c45b48d2055a154fae74f5c348
+
+pkgname = emacs-showtip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5059d05c29e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-showtip
+pkgver=0.01
+pkgrel=1
+pkgdesc="An extension for emacs to show tip at curser"
+arch=('any')
+url="https://www.emacswiki.org/emacs/showtip.el"
+license=('GPL')
+depends=('emacs')
+source=(https://www.emacswiki.org/emacs/download/showtip.el)
+md5sums=('9f23b6c45b48d2055a154fae74f5c348')
+
+build() {
+ emacs -Q -batch -L . -f batch-byte-compile showtip.el
+}
+
+package() {
+ install -D -m 644 "$srcdir/showtip.el" \
+ "$pkgdir/usr/share/emacs/site-lisp/showtip.el"
+ install -D -m 644 "$srcdir/showtip.elc" \
+ "$pkgdir/usr/share/emacs/site-lisp/showtip.elc"
+}