summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPoscat2019-12-04 21:48:43 +0800
committerPoscat2019-12-04 21:48:43 +0800
commit8743f05b7828f25ebd952856c148888365cb95b4 (patch)
treedc8a9a65560bfe09f90bb0c8b549bce6d1ec7cac
downloadaur-8743f05b7828f25ebd952856c148888365cb95b4.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e03933e36d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = emacs-smart-mode-line
+ pkgdesc = A powerful and beautiful mode-line for Emacs.
+ pkgver = 2.13
+ pkgrel = 1
+ url = https://github.com/Malabarba/smart-mode-line
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-rich-minority
+ source = https://github.com/Malabarba/smart-mode-line/archive/2.13.tar.gz
+ sha256sums = 4b7dbebf0a6a501208bcf82950b7c08aac86ae69419d1fc1d55e77c85cafdc69
+
+pkgname = emacs-smart-mode-line
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..091d20e9ae25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Poscat <poscat@mail.poscat.moe>
+
+pkgname=emacs-smart-mode-line
+pkgver=2.13
+pkgrel=1
+pkgdesc="A powerful and beautiful mode-line for Emacs."
+arch=(any)
+url="https://github.com/Malabarba/smart-mode-line"
+license=('GPL3')
+depends=('emacs' 'emacs-rich-minority')
+source=("https://github.com/Malabarba/smart-mode-line/archive/${pkgver}.tar.gz")
+sha256sums=('4b7dbebf0a6a501208bcf82950b7c08aac86ae69419d1fc1d55e77c85cafdc69')
+
+build() {
+ cd "${srcdir}/smart-mode-line-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/smart-mode-line-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/smart-mode-line/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/smart-mode-line/"
+}