summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-02 17:10:04 -0400
committerAlex Whitt2017-05-02 17:10:04 -0400
commit61d62cfa48190ddb6d233bb08fc25ebb29f8c918 (patch)
tree4ac7e1feab39723ff823333c78e88ee307d5cd46
downloadaur-61d62cfa48190ddb6d233bb08fc25ebb29f8c918.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD38
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f87b63f19e1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Tue May 2 21:09:48 UTC 2017
+pkgbase = emacs-spaceline
+ pkgdesc = Powerline theme from Spacemacs
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/TheBB/spaceline
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-dash
+ depends = emacs-powerline
+ depends = emacs-s
+ optdepends = emacs-persp-mode: Show current workspace name
+ optdepends = emacs-winum: Show current window number
+ optdepends = emacs-auto-compile: Show auto-compile warnings as they occur
+ optdepends = emacs-anzu: Show total number of matches while searching
+ optdepends = emacs-flycheck: Show number of errors, warnings, and notifications
+ optdepends = emacs-erc: IRC client notifications
+ optdepends = emacs-org-mode: Show currently-clocking org-mode task
+ optdepends = emacs-org-pomodoro: Show pomodoro clocks
+ optdepends = emacs-pyenv-mode: Show currently active environments
+ optdepends = emacs-pyvenv: Show currently active environments
+ optdepends = emacs-nyan-mode: Show current position in the buffer with kittens and rainbows
+ optdepends = emacs-fancy-battery: Shows battery information in the modeline
+ optdepends = emacs-evil: Show current Evil state
+ provides = emacs-spaceline
+ source = emacs-spaceline-2.0.1.tar.gz::https://github.com/TheBB/spaceline/archive/v2.0.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-spaceline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..443dd1ad9ed4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-spaceline
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Powerline theme from Spacemacs"
+url="https://github.com/TheBB/spaceline"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-dash' 'emacs-powerline' 'emacs-s')
+optdepends=("emacs-persp-mode: Show current workspace name"
+ "emacs-winum: Show current window number"
+ "emacs-auto-compile: Show auto-compile warnings as they occur"
+ "emacs-anzu: Show total number of matches while searching"
+ "emacs-flycheck: Show number of errors, warnings, and notifications"
+ "emacs-erc: IRC client notifications"
+ "emacs-org-mode: Show currently-clocking org-mode task"
+ "emacs-org-pomodoro: Show pomodoro clocks"
+ "emacs-pyenv-mode: Show currently active environments"
+ "emacs-pyvenv: Show currently active environments"
+ "emacs-nyan-mode: Show current position in the buffer with kittens and rainbows"
+ "emacs-fancy-battery: Shows battery information in the modeline"
+ "emacs-evil: Show current Evil state")
+makedepends=('git')
+provides=('emacs-spaceline')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/TheBB/spaceline/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/spaceline-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile spaceline*.el
+}
+
+package() {
+ cd "${srcdir}/spaceline-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/spaceline"
+ install -m644 spaceline*.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/spaceline/"
+}