summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-26 17:18:05 -0400
committerAlex Whitt2017-05-26 17:18:05 -0400
commitf4d44eb78f3f7d2693e321f5f81aae15b2d016ed (patch)
tree2cbaeff0fac4bd4415e40024eb6917e74e7e84b1
parentbaa4928d5a0a045931cfba76a5a40590269229be (diff)
downloadaur-f4d44eb78f3f7d2693e321f5f81aae15b2d016ed.tar.gz
Seemingly working now.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--emacs-spacemacs-funcs.install21
-rw-r--r--spacemacs-funcs.el7
4 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afc3d3cda743..f802483330cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu May 25 22:59:33 UTC 2017
+# Fri May 26 21:16:33 UTC 2017
pkgbase = emacs-spacemacs-funcs
pkgdesc = Useful functions from the Spacemacs project
pkgver = 0.200.9
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/syl20bnr/spacemacs
install = emacs-spacemacs-funcs.install
arch = any
@@ -11,7 +11,7 @@ pkgbase = emacs-spacemacs-funcs
depends = emacs
source = spacemacs-funcs.el
source = emacs-spacemacs-funcs-0.200.9.tar.gz::https://github.com/syl20bnr/spacemacs/archive/v0.200.9.tar.gz
- sha256sums = eb0382f22b73e3be609ac585dd24ef3a5ecb317067d13f7f06d85ec7887779a2
+ sha256sums = 395c6376f3b76fbc020024dfb176c7eeb075b86004d8ecfbee89b8be457bd4a4
sha256sums = 81e8fc56421e00405cba2d78f8b5e14b1d9e8e23803dcf43eb8e89b72273ea1b
pkgname = emacs-spacemacs-funcs
diff --git a/PKGBUILD b/PKGBUILD
index bd5c77ae2ee6..768f19ce7332 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgmaintainer=syl20bnr
_pkgdestdirname=spacemacs-funcs
_versionprefix=v
pkgver=0.200.9
-pkgrel=2
+pkgrel=3
pkgdesc="Useful functions from the Spacemacs project"
pkgname=emacs-${_pkgdestdirname}
arch=(any)
@@ -14,7 +14,7 @@ license=('GPL3')
depends=('emacs')
source=("spacemacs-funcs.el"
"$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
-sha256sums=('eb0382f22b73e3be609ac585dd24ef3a5ecb317067d13f7f06d85ec7887779a2'
+sha256sums=('1cb471431cbc7b1654a16f9dbe8c56dac044010d7f1eaa998b31a966dedc5198'
'81e8fc56421e00405cba2d78f8b5e14b1d9e8e23803dcf43eb8e89b72273ea1b')
install=${pkgname}.install
diff --git a/emacs-spacemacs-funcs.install b/emacs-spacemacs-funcs.install
index 000eec4443a3..b2a7c34d96b9 100644
--- a/emacs-spacemacs-funcs.install
+++ b/emacs-spacemacs-funcs.install
@@ -2,15 +2,28 @@ post_install () {
cat << EOF
-==> Add this code to your .emacs file to include these functions:
+==> Add this code to your .emacs file to include the core functions:
(require 'spacemacs-funcs)
-==> Or do the above with use-package:
+==> For each additional Spacemacs layer from which you want utility functions (probably at least spacemacs-base):
-(use-package spacemacs-funcs)
+(setq spacemacs-funcs-enabled-layers '("spacemacs-base"
+ "<name of other layer>"))
+
+==> If you enabled some layers, then:
+
+(spacemacs-funcs-load-layers)
+
+==> Or do all the above with use-package:
+
+(use-package spacemacs-funcs
+ :config
+ (setq spacemacs-funcs-enabled-layers '("spacemacs-base"
+ "<name of other layer>")) ; To enable some layers
+ (spacemacs-funcs-load-layers)) ; If extra layers are enabled
+)
-==> NOTE: This is a really rough include, and basically imports all of the *funcs.el files in the Spacemacs project. There are bound to be functions that don't work, because they reference variables outside of these files (and therefore outside of the scope of this package.) Over time I might think about refining this, but for now it gets me the utilities I need.
EOF
}
diff --git a/spacemacs-funcs.el b/spacemacs-funcs.el
index dd067f7fe5a0..e93824686e52 100644
--- a/spacemacs-funcs.el
+++ b/spacemacs-funcs.el
@@ -41,11 +41,8 @@
"Load layers specified in spacemacs-funcs-enabled-layers."
(dolist (file-string (file-expand-wildcards "/usr/share/emacs/site-lisp/spacemacs-funcs/layers*" t))
(if (and (string-match "layers_.*_\\([[:alnum:]-]+\\)_funcs.elc" file-string)
- (member (match-string 1) spacemacs-funcs-enabled-layers))
- (message "match: %s %s %s" file-string (match-string 1 file-string) spacemacs-funcs-enabled-layers)
- (sit-for 1)
- )));(load file-string))))
-
+ (member (match-string 1 file-string) spacemacs-funcs-enabled-layers))
+ (load file-string))))
(provide 'spacemacs-funcs)