summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-01-03 22:11:31 +0100
committerhaawda2019-01-03 22:11:31 +0100
commit7dec1c1fb5be80e41198ffa22a88602a7e557b6d (patch)
tree7a2c8abe91339057e2427482599e41bb0686cda0
parent9aa7e7db50a4c76eb178cf56e44ab4c53f0aa083 (diff)
downloadaur-7dec1c1fb5be80e41198ffa22a88602a7e557b6d.tar.gz
adopted, small changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec00c742521f..5be6315321af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-swiper
- pkgdesc = Ivy - a generic completion frontend for Emacs, Swiper - isearch with an overview, and more. Oh, man!
+ pkgdesc = Ivy - a generic completion frontend for Emacs, Swiper - isearch with an overview
pkgver = 0.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/abo-abo/swiper
arch = any
license = GPL3
@@ -9,7 +9,7 @@ pkgbase = emacs-swiper
depends = emacs
provides = emacs-swiper
conflicts = emacs-swiper
- source = https://github.com/abo-abo/swiper/archive/0.10.0.tar.gz
+ source = emacs-swiper-0.10.0.tar.gz::https://github.com/abo-abo/swiper/archive/0.10.0.tar.gz
sha256sums = b507579202e438103f2bd1925b4a5ddb9dccb85efdca5faf786d07f58521816e
pkgname = emacs-swiper
diff --git a/PKGBUILD b/PKGBUILD
index 81b82bfd9aec..33906de49feb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: sballert <sballert@posteo.de>
+# Contributor: sballert <sballert@posteo.de>
# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-swiper
pkgver=0.10.0
-pkgrel=1
-pkgdesc="Ivy - a generic completion frontend for Emacs, Swiper - isearch with an overview, and more. Oh, man!"
+pkgrel=2
+pkgdesc="Ivy - a generic completion frontend for Emacs, Swiper - isearch with an overview"
url="https://github.com/abo-abo/swiper"
arch=('any')
license=('GPL3')
@@ -12,16 +13,16 @@ depends=('emacs')
makedepends=('git')
provides=('emacs-swiper')
conflicts=('emacs-swiper')
-source=("https://github.com/abo-abo/swiper/archive/${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/abo-abo/swiper/archive/${pkgver}.tar.gz")
sha256sums=('b507579202e438103f2bd1925b4a5ddb9dccb85efdca5faf786d07f58521816e')
build() {
- cd "${srcdir}/swiper-${pkgver}"
+ cd "swiper-${pkgver}"
make clean test compile
}
package() {
- cd "${srcdir}/swiper-${pkgver}"
+ cd "swiper-${pkgver}"
install -d "${pkgdir}/usr/share/emacs/site-lisp/swiper"
install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/swiper/"
}