summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-27 12:46:45 -0400
committerAlex Whitt2017-04-27 12:46:45 -0400
commitd58cf3ad62e3caf3307012c1cedd21a2e61913a4 (patch)
treeedff11f885558a10a819fe3975df77f18afcdb7b
downloadaur-d58cf3ad62e3caf3307012c1cedd21a2e61913a4.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05173ff8d045
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Apr 27 16:46:20 UTC 2017
+pkgbase = emacs-swiper
+ pkgdesc = Ivy - a generic completion frontend for Emacs, Swiper - isearch with an overview, and more. Oh, man!
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://github.com/abo-abo/swiper
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-swiper
+ conflicts = emacs-swiper
+ source = https://github.com/abo-abo/swiper/archive/0.9.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-swiper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abd5f20f1ea6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-swiper
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Ivy - a generic completion frontend for Emacs, Swiper - isearch with an overview, and more. Oh, man!"
+url="https://github.com/abo-abo/swiper"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-swiper')
+conflicts=('emacs-swiper')
+source=("https://github.com/abo-abo/swiper/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/swiper-${pkgver}"
+ make clean test compile
+}
+
+package() {
+ cd "${srcdir}/swiper-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/swiper"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/swiper/"
+}