summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Beaumont2015-08-17 23:07:45 +0200
committerAlfredo Beaumont2015-08-17 23:07:45 +0200
commitef31eefa4fdae8f69d3b65337587747944fd33b4 (patch)
tree2b5f5a53eafc2989e4573687bbe55b70c8026608
downloadaur-ef31eefa4fdae8f69d3b65337587747944fd33b4.tar.gz
Emacs textile mode 6
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--emacs-textile-mode.install19
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a92e13b70e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = emacs-textile-mode
+ pkgdesc = Emacs major mode for editing files in Textile markup
+ pkgver = 6
+ pkgrel = 2
+ url = http://dev.nozav.org/textile-mode.html
+ install = emacs-textile-mode.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = emacs
+ source = http://dev.nozav.org/scripts/textile-mode.el
+ md5sums = cf663f90d0eff12260e3e3dd6ec72a50
+
+pkgname = emacs-textile-mode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0317d05282a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Alfredo Beaumont <alfredo.beaumont@gmail.com>
+pkgname=emacs-textile-mode
+_pkgname=textile-mode
+pkgver=6
+pkgrel=2
+pkgdesc="Emacs major mode for editing files in Textile markup"
+arch=('i686' 'x86_64')
+url="http://dev.nozav.org/textile-mode.html"
+license=('GPL')
+groups=()
+depends=('emacs')
+install=emacs-textile-mode.install
+source=(http://dev.nozav.org/scripts/textile-mode.el)
+noextract=()
+md5sums=('cf663f90d0eff12260e3e3dd6ec72a50')
+
+build() {
+ # Install the mode for Emacs
+ install -D -m644 $_pkgname.el $pkgdir/usr/share/emacs/site-lisp/$_pkgname.el
+}
diff --git a/emacs-textile-mode.install b/emacs-textile-mode.install
new file mode 100644
index 000000000000..c5eaf149c7bb
--- /dev/null
+++ b/emacs-textile-mode.install
@@ -0,0 +1,19 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'textile-mode)
+(add-to-list 'auto-mode-alist '("\\.textile\\'" . textile-mode))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*