summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuki-san2015-06-11 15:57:24 +0900
committeryuki-san2015-06-11 15:57:24 +0900
commitbeb952eab4cf73afbb724b88a8b43fba6194b09c (patch)
treef60dc4907f52efe321f49f962fc3a0a74ec1f871
downloadaur-beb952eab4cf73afbb724b88a8b43fba6194b09c.tar.gz
Initial commit for AUR4
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD43
-rw-r--r--emacs-twittering-mode-git.install8
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f863f24f14d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = emacs-twittering-mode-git
+ pkgdesc = An Emacs major mode for Twitter (git version)
+ pkgver = v3.0.0.29.gb04a3af
+ pkgrel = 1
+ url = http://twmode.sourceforge.net/index.html
+ install = emacs-twittering-mode-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = emacs>=23.1
+ depends = curl
+ optdepends = gnupg: For keeping an OAuth authorized token in a local storage encrypted with master password
+ provides = emacs-twittering-mode
+ conflicts = emacs-twittering-mode
+ source = twittering-mode::git+https://github.com/hayamiz/twittering-mode.git
+ md5sums = SKIP
+
+pkgname = emacs-twittering-mode-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e64bd55eee03
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.{gz,xz}
+twittering-mode/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61db24ccf79b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: yuki-san <yuki.from.akita _at_ gmail.com>
+
+pkgname=emacs-twittering-mode-git
+pkgver=v3.0.0.29.gb04a3af
+pkgrel=1
+pkgdesc="An Emacs major mode for Twitter (git version)"
+arch=('any')
+url="http://twmode.sourceforge.net/index.html"
+license=('GPL')
+depends=('emacs>=23.1' 'curl')
+makedepends=('git')
+optdepends=('gnupg: For keeping an OAuth authorized token in a local storage encrypted with master password')
+install=emacs-twittering-mode-git.install
+conflicts=('emacs-twittering-mode')
+provides=('emacs-twittering-mode')
+source=('twittering-mode::git+https://github.com/hayamiz/twittering-mode.git')
+md5sums=('SKIP')
+
+_gitname='twittering-mode'
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ local ver="$(git describe --long)"
+ printf "%s" "${ver//-/.}"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ emacs -q -batch -f batch-byte-compile twittering-mode.el
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -d -m 755 "$pkgdir"/usr/share/emacs/site-lisp
+ install -c -m 644 twittering-mode.el "$pkgdir"/usr/share/emacs/site-lisp
+ install -c -m 644 twittering-mode.elc "$pkgdir"/usr/share/emacs/site-lisp
+
+ install -d -m 755 "$pkgdir"/usr/share/doc/emacs-twittering-mode-git
+ install -c -m 644 README.markdown "$pkgdir"/usr/share/doc/emacs-twittering-mode-git
+ install -c -m 644 README.ja "$pkgdir"/usr/share/doc/emacs-twittering-mode-git
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/emacs-twittering-mode-git.install b/emacs-twittering-mode-git.install
new file mode 100644
index 000000000000..2387b29e973c
--- /dev/null
+++ b/emacs-twittering-mode-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat << EOF
+==> Put the following in your emacs configuration file (e.g. \$HOME/.emacs) to use twittering-mode
+
+(require 'twittering-mode)
+
+EOF
+}