summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 17:02:34 +0100
committerBartłomiej Piotrowski2018-01-05 17:02:34 +0100
commit65592924b984817d0b6cd6ec91e4c38b4aad24b2 (patch)
treeb8ac6b74614a323161592f9079f6662a79a82ed2
downloadaur-65592924b984817d0b6cd6ec91e4c38b4aad24b2.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
-rw-r--r--emacs-w3m-cvs.install8
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..729db74d09ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-w3m-cvs
+ pkgdesc = w3m browser for Emacs (cvs)
+ pkgver = 20140530
+ pkgrel = 2
+ url = http://emacs-w3m.namazu.org/
+ install = emacs-w3m-cvs.install
+ arch = any
+ license = GPL
+ makedepends = cvs
+ makedepends = autoconf
+ depends = emacs
+ depends = w3m
+ provides = emacs-w3m
+ conflicts = emacs-w3m
+
+pkgname = emacs-w3m-cvs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87f610e4cb3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id: PKGBUILD 196308 2016-11-18 14:24:11Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: James Cozine <jmcozine@gmail.com>
+
+pkgname="emacs-w3m-cvs"
+pkgver=20140530
+pkgrel=2
+pkgdesc="w3m browser for Emacs (cvs)"
+arch=('any')
+url="http://emacs-w3m.namazu.org/"
+license=('GPL')
+depends=('emacs' 'w3m')
+makedepends=('cvs' 'autoconf')
+provides=('emacs-w3m')
+conflicts=('emacs-w3m')
+install="emacs-w3m-cvs.install"
+
+_cvsroot=":pserver:anonymous:@cvs.namazu.org:/storage/cvsroot"
+_cvsmod="emacs-w3m"
+
+prepare() {
+ cd "$srcdir"
+ if [ -d ${_cvsmod}/CVS ]; then
+ cd ${_cvsmod}
+ else
+ cvs -z3 -d $_cvsroot co -D $pkgver -f ${_cvsmod}
+ cd ${_cvsmod}
+ fi
+ sed -i 's|1234|123456|' aclocal.m4
+ autoconf
+}
+
+build() {
+ cd "$srcdir"
+
+ cp -r ${_cvsmod} ${_cvsmod}-build
+ cd ${_cvsmod}-build
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/${_cvsmod}-build
+ make prefix="$pkgdir/usr" install
+}
diff --git a/emacs-w3m-cvs.install b/emacs-w3m-cvs.install
new file mode 100644
index 000000000000..fc83f4f4ff14
--- /dev/null
+++ b/emacs-w3m-cvs.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ">>" Add the following to your .emacs:
+ echo ">> (require 'w3m-load)"
+}
+
+post_upgrade() {
+ post_install $1
+}