summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-11 13:20:35 -0400
committerAlex Whitt2017-05-11 13:20:35 -0400
commitf79765e2f8876f398a26b509cb48ef1f50a32785 (patch)
treee76380dacbc0e9cf24ead055419fa464594bf4c8
downloadaur-f79765e2f8876f398a26b509cb48ef1f50a32785.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-which-key.install21
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc33066aeb79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu May 11 17:20:10 UTC 2017
+pkgbase = emacs-which-key
+ pkgdesc = Emacs package that displays available keybindings in popup
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/justbur/emacs-which-key
+ install = emacs-which-key.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = emacs-which-key-2.0.1.tar.gz::https://github.com/justbur/emacs-which-key/archive/v2.0.1.tar.gz
+ sha256sums = da687208d29e3905df3ece165615b6683cf3b007183cb3c7f7071aaf6c782038
+
+pkgname = emacs-which-key
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd12785170fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=emacs-which-key
+_pkgmaintainer=justbur
+_pkgdestdirname=which-key
+_versionprefix=v
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Emacs package that displays available keybindings in popup"
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('da687208d29e3905df3ece165615b6683cf3b007183cb3c7f7071aaf6c782038')
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile which-key.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 which-key.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}
diff --git a/emacs-which-key.install b/emacs-which-key.install
new file mode 100644
index 000000000000..380a2d9c3bc0
--- /dev/null
+++ b/emacs-which-key.install
@@ -0,0 +1,21 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'which-key)
+(which-key-mode 1)
+
+==> Or, with use-package:
+
+(use-package which-key
+ :config
+ (which-key-mode 1))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}