summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-04 13:27:57 -0400
committerAlex Whitt2017-05-04 13:27:57 -0400
commit97568f151b50271da3ee56116705fc1937c88f06 (patch)
tree9ad94cf546f94062e4d854fd8837a5409bb5e606
parent8f14c2160a4e986c452b2fdc05549ddcadd92aad (diff)
downloadaur-97568f151b50271da3ee56116705fc1937c88f06.tar.gz
Adding sha256sums and install script
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD3
-rw-r--r--emacs-winum.install30
3 files changed, 35 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9192847569f8..c00f1da382d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Wed May 3 18:15:53 UTC 2017
+# Thu May 4 17:27:38 UTC 2017
pkgbase = emacs-winum
pkgdesc = Window numbers for Emacs - Navigate windows and frames using numbers
pkgver = 1.0.0
pkgrel = 1
url = https://github.com/deb0ch/emacs-winum
+ install = emacs-winum.install
arch = any
license = GPL3
depends = emacs
source = emacs-winum-1.0.0.tar.gz::https://github.com/deb0ch/emacs-winum/archive/1.0.0.tar.gz
- sha256sums = SKIP
+ sha256sums = 1c3a0b56bcae9775cd2d1b4242634d21826d7c7c543d226d4f255a5959130447
pkgname = emacs-winum
diff --git a/PKGBUILD b/PKGBUILD
index 512d4cef8bb0..12799f77120b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,8 @@ url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
license=('GPL3')
depends=('emacs')
source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
-sha256sums=('SKIP')
+sha256sums=('1c3a0b56bcae9775cd2d1b4242634d21826d7c7c543d226d4f255a5959130447')
+install=${pkgname}.install
build() {
cd "${srcdir}/${_pkgsrcname}-${pkgver}"
diff --git a/emacs-winum.install b/emacs-winum.install
new file mode 100644
index 000000000000..8d1dc70fc938
--- /dev/null
+++ b/emacs-winum.install
@@ -0,0 +1,30 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'winum)
+(winum-mode)
+
+==> If you are using spaceline or another modeline modifier that
+ references winum internally, put this before your initialization
+ of winum:
+
+(setq winum-auto-setup-mode-line nil)
+
+==> Or do the above with use-package:
+
+(use-package winum
+ :init
+ (setq winum-auto-setup-mode-line nil) ;If using spaceline or the like
+
+ :config
+ (winum-mode))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}