summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEsben Haabendal2017-12-18 09:18:13 +0100
committerEsben Haabendal2017-12-18 09:22:41 +0100
commit4af509459558c32b8dac7ff9d43c261dd3e3c107 (patch)
treeab87809e099e7d2635935d640def100e37612112
parent319a680651d5d700f3a264221563e540f25607d7 (diff)
downloadaur-4af509459558c32b8dac7ff9d43c261dd3e3c107.tar.gz
Rename github org/repo internal variables
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4b7a45afde9..a7f67eac0171 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,35 @@
# Maintainer: Esben Haabendal <esben@haabendal.dk>
pkgname=emacs-with-editor-git
-_gitprofile="magit"
-_gitrepo="with-editor"
+_github_org="magit"
+_github_repo="with-editor"
pkgver=2.6.0
pkgrel=1
pkgdesc="Use the Emacsclient as the $EDITOR of child processes"
arch=('any')
-url="http://github.com/${_gitprofile}/${_gitrepo}"
+url="http://github.com/${_github_org}/${_github_repo}"
license=('GPL3')
depends=('emacs>=24.4')
provides=('emacs-with-editor')
install="${pkgname}.install"
-source=("git+https://github.com/${_gitprofile}/${_gitrepo}.git")
+source=("git+https://github.com/${_github_org}/${_github_repo}.git")
md5sums=('SKIP')
pkgver() {
- cd "$_gitrepo"
+ cd "$srcdir/${_github_repo}"
# Latest annotated tag (release)
git describe --abbrev=0 | sed 's/^v//'
}
build() {
+ cd "$srcdir/${_github_repo}"
unset EMACS
- cd "$_gitrepo"
make EFLAGS="-L /usr/share/emacs/site-lisp -L ${srcdir}/${_gitrepo}/lisp" \
lisp info
}
package() {
- cd "$_gitrepo"
+ cd "$srcdir/${_github_repo}"
mkdir -p ${pkgdir}/usr/share/emacs/site-lisp
install -m 644 with-editor.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
mkdir -p ${pkgdir}/usr/share/info