summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEsben Haabendal2016-01-31 09:00:31 +0100
committerEsben Haabendal2016-01-31 09:02:21 +0100
commitd6b8754f28421c1f6d326785d47e66eec86af269 (patch)
tree2daf4ddbc9aa45c6ac17fbea769f11e7e81d18e2
downloadaur-d6b8754f28421c1f6d326785d47e66eec86af269.tar.gz
Initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--emacs-with-editor-git.install24
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8df95ec71608
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jan 31 08:02:11 UTC 2016
+pkgbase = emacs-with-editor-git
+ pkgdesc = Use the Emacsclient as the of child processes
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = http://github.com/magit/with-editor
+ install = emacs-with-editor-git.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-dash=2.12.1
+ provides = emacs-with-editor
+ source = git+https://github.com/magit/with-editor.git
+ md5sums = SKIP
+
+pkgname = emacs-with-editor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6530553d88c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Esben Haabendal <esben@haabendal.dk>
+
+pkgname=emacs-with-editor-git
+_gitprofile="magit"
+_gitrepo="with-editor"
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="Use the Emacsclient as the $EDITOR of child processes"
+arch=('any')
+url="http://github.com/${_gitprofile}/${_gitrepo}"
+license=('GPL3')
+depends=('emacs' 'emacs-dash=2.12.1')
+provides=('emacs-with-editor')
+install="${pkgname}.install"
+source=("git+https://github.com/${_gitprofile}/${_gitrepo}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ # Git tag
+ echo $(git describe --tags|sed 's/v//;s/-/./g')
+}
+
+build() {
+ cd "$_gitrepo"
+ make EFLAGS="-L /usr/share/emacs/site-lisp -L /usr/share/emacs/site-lisp/dash -L ${srcdir}/${_gitrepo}/lisp" \
+ lisp info
+}
+
+package() {
+ cd "$_gitrepo"
+ mkdir -p ${pkgdir}/usr/share/emacs/site-lisp
+ install -m 644 with-editor.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
+ mkdir -p ${pkgdir}/usr/share/info
+ install -m 644 with-editor.info ${pkgdir}/usr/share/info/
+}
diff --git a/emacs-with-editor-git.install b/emacs-with-editor-git.install
new file mode 100644
index 000000000000..10c08d4ce5b4
--- /dev/null
+++ b/emacs-with-editor-git.install
@@ -0,0 +1,24 @@
+infodir=/usr/share/info
+filelist=(with-editor.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+op=$1
+shift
+$op $*