summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-04 08:17:22 +0200
committersballert2018-09-04 08:17:22 +0200
commit170ead7f27b9d435f6cdf575322a3d7a34ec7d65 (patch)
tree1d1e7671591b92c4fcf17a13b6929fee41f9d28c
downloadaur-170ead7f27b9d435f6cdf575322a3d7a34ec7d65.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e01c066ccd32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-ws-butler-git
+ pkgdesc = Unobtrusively trim extraneous white-space *ONLY* in lines edited.
+ pkgver = r59.52321b9
+ pkgrel = 1
+ url = https://github.com/lewang/ws-butler
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-ws-butler
+ conflicts = emacs-ws-butler
+ source = git+https://github.com/lewang/ws-butler.git
+ sha256sums = SKIP
+
+pkgname = emacs-ws-butler-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..788bf83a3793
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="lewang"
+_gitrepo="ws-butler"
+
+pkgname=emacs-ws-butler-git
+pkgver=r59.52321b9
+pkgrel=1
+pkgdesc="Unobtrusively trim extraneous white-space *ONLY* in lines edited."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-ws-butler')
+conflicts=('emacs-ws-butler')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}