summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:24:29 +0200
committerStefan Husmann2015-06-09 00:24:29 +0200
commit36cca187700d384a2a12157f4d70acb9b2de1c69 (patch)
tree6faf4b67848097f1a9dfcc69be79c986ae5b5bf0
downloadaur-36cca187700d384a2a12157f4d70acb9b2de1c69.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
-rw-r--r--emacs-xlicense.install11
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..404ea681e97b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = emacs-xlicense
+ pkgdesc = eXtra License mode for Emacs
+ pkgver = 2014_07_08
+ pkgrel = 1
+ url = http://www.emacswiki.org/emacs/ExtraLicense
+ install = emacs-xlicense.install
+ arch = any
+ license = GPL3
+ depends = licenses
+ source = git+https://github.com/stefanhusmann/arch-xlicense
+ md5sums = SKIP
+
+pkgname = emacs-xlicense
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d74a857deaa7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Nathan Owe <ndowens.aur at gmail dot com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-xlicense
+pkgver=2014_07_08
+pkgrel=1
+pkgdesc="eXtra License mode for Emacs"
+arch=('any')
+url="http://www.emacswiki.org/emacs/ExtraLicense"
+license=('GPL3')
+depends=('licenses')
+source=("git+https://github.com/stefanhusmann/arch-xlicense")
+md5sums=('SKIP')
+install=emacs-xlicense.install
+_gitname=arch-xlicense
+
+pkgver () {
+ cd "$srcdir/$_gitname"
+ git log -1 --format="%cd" --date=short | tr - _
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm644 xlicense.el \
+ "$pkgdir/usr/share/emacs/site-lisp/xlicense.el"
+ ln -s /usr/share/licenses/common "$pkgdir/usr/share/emacs/site-lisp/licenses"
+}
diff --git a/emacs-xlicense.install b/emacs-xlicense.install
new file mode 100644
index 000000000000..7c5c555d6fe0
--- /dev/null
+++ b/emacs-xlicense.install
@@ -0,0 +1,11 @@
+post_install() {
+cat << EOF
+ load xlicense.el:
+ (load-library "/usr/share/emacs/site-lisp/xlicense.el")
+
+EOF
+}
+
+post_upgrade() {
+ post_install
+}