summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJáchym Tomášek2020-08-16 15:24:00 +0200
committerJáchym Tomášek2020-08-16 15:24:00 +0200
commit6e6e2136234d88f6483b00067bd11777351c683e (patch)
treee837f7f5fd26bb1cdfe836fd279d2ec3e2b2a87e
parentc5918590de31a298127c7cdfd5a7e499b98d8e14 (diff)
downloadaur-6e6e2136234d88f6483b00067bd11777351c683e.tar.gz
Add 27.1 version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 21 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d5227938a01..89a78394dfe8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = emacs-xwidgets
- pkgdesc = Good old emacs with xwidgets support
- pkgver = 26.1_rc1
- pkgrel = 1
- url = http://www.gnu.org/software/emacs/emacs.html
+ pkgdesc = The extensible, customizable, self-documenting real-time display editor with xwidgets support
+ pkgver = 27.1
+ pkgrel = 2
+ url = https://www.gnu.org/software/emacs/emacs.html
arch = x86_64
license = GPL3
depends = librsvg
@@ -14,18 +14,13 @@ pkgbase = emacs-xwidgets
depends = gtk3
depends = webkit2gtk
depends = hicolor-icon-theme
- depends = gconf
depends = desktop-file-utils
depends = alsa-lib
- depends = libmagick6
depends = gnutls
+ depends = jansson
provides = emacs
conflicts = emacs
- source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-26.1-rc1.tar.xz
- source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-26.1-rc1.tar.xz.sig
- validpgpkeys = B29426DEFB07724C3C35E5D36592E9A3A0B0F199
- validpgpkeys = 28D3BED851FDF3AB57FEF93C233587A47C207910
- sha1sums = 8ba00629a1799c14e02c643e26bb9fa5009ae8fa
+ source = https://ftp.gnu.org/gnu/emacs/emacs-27.1.tar.xz
sha1sums = SKIP
pkgname = emacs-xwidgets
diff --git a/PKGBUILD b/PKGBUILD
index 86aefcd405f8..185176c2627b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,28 @@
-#
-# Maintainer: Romain Gautier <romain.gautier at nimamoh dot net>
-#
-pkgname=emacs-xwidgets
-pkgver=26.1_rc1
-pkgrel=1
-
-# custom variable. the underlying true pkgname
-appname=emacs
-appver=${pkgver::-4}
+# Maintainer: Jáchym Tomášek <jachym.tomasek@tutanota.com>
-pkgdesc="Good old emacs with xwidgets support"
+pkgname=emacs-xwidgets
+pkgver=27.1
+pkgrel=2
+pkgdesc="The extensible, customizable, self-documenting real-time display editor with xwidgets support"
arch=('x86_64')
-url="http://www.gnu.org/software/emacs/emacs.html"
+url="https://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk3' 'webkit2gtk' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib' 'libmagick6' 'gnutls')
+depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk3' 'webkit2gtk' 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'gnutls' 'jansson')
+source=(https://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.xz)
+sha1sums=('SKIP')
conflicts=('emacs')
provides=('emacs')
-validpgpkeys=('B29426DEFB07724C3C35E5D36592E9A3A0B0F199' '28D3BED851FDF3AB57FEF93C233587A47C207910')
-# ftp://alpha.gnu.org/gnu/emacs/pretest/
-source=(ftp://alpha.gnu.org/gnu/emacs/pretest/$appname-${pkgver//_/-}.tar.xz{,.sig})
-sha1sums=('8ba00629a1799c14e02c643e26bb9fa5009ae8fa'
- 'SKIP')
build() {
- cd "$srcdir"/$appname-${appver}
- PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig" \
- ac_cv_lib_gif_EGifPutExtensionLast=yes ./configure \
- --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --localstatedir=/var --mandir=/usr/share/man \
- --with-gameuser=:games \
- --with-mailutils \
- --with-x-toolkit=gtk3 --with-xft \
- --with-xwidgets \
- --with-modules
+ cd "$srcdir"/emacs-$pkgver
+ ac_cv_lib_gif_EGifPutExtensionLast=yes ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --with-x-toolkit=gtk3 --with-xft --with-wide-int \
+ --with-modules --with-xwidgets
make
}
package() {
- cd "$srcdir"/$appname-${appver}
+ cd "$srcdir"/emacs-$pkgver
make DESTDIR="$pkgdir" install
# remove conflict with ctags package
@@ -45,11 +30,5 @@ package() {
mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
# fix user/root permissions on usr/share files
- # XXX: emacs stores using major version. Since we build a rc we have to strip things down
- find "$pkgdir"/usr/share/emacs/${appver} -exec chown root:root {} \;
- # fix perms on /var/games
- chmod 775 "$pkgdir"/var/games
- chmod 775 "$pkgdir"/var/games/emacs
- chmod 664 "$pkgdir"/var/games/emacs/*
- chown -R root:games "$pkgdir"/var/games
+ find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
}